Find the answer to your Linux question:
Results 1 to 5 of 5
Hi All, So I'm in a really crappy position with my system. I've gone through three video cards in 2 months...I'm waiting to hear back from the guy to return ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998

    safe graphics mode?


    Hi All,

    So I'm in a really crappy position with my system. I've gone through three video cards in 2 months...I'm waiting to hear back from the guy to return this one and then going to piece this system, sell what I can and then finance a new system (probably nothing even close to this one can't afford it )

    So, what I need. I can boot into Ubuntu with safe graphics mode but the only way I know how to do this is to install it in that mode (when I pop in my bootable USB and get the menu to select what I want to do I have to click F4 and then select safe graphics mode).

    How do I access this mode without having to reinstall (I am currently in it) but the video card isn't completely fried yet and I'd like to install the nvidia driver and once it starts acting up I'll just toss it back into the safe graphics mode.

    Thanks all
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  2. #2
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    This is how I'd do it:

    Boot in to the recovery console. Type nano /etc/X11/xorg.conf. Arrow down to Section "Device", Replace the Driver line from what's there with Driver "vesa". Check Section "Screen", if there is a default video mode defined that exceeds safe specs for your card or monitor, replace with a safe resolution. If not, just leave it alone.

    Save ([Ctrl +X] , y) and type reboot. When the computer comes back up, you will be using the vesa driver (which should be safe for 99% of the video cards on the market).

    Edit:
    I would also suggest editing the /boot/grub/menu.lst and on the kernel line(s), remove the options "quiet" and "splash" and add the option vga=771 . This will keep your text mode low and safe as well, hopefully avoiding possible corruption of the video text mode when X loads and allowing some resources.

  3. #3
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    unfortunately I don't think I can boot into recovery mode once I install the drivers, I think it freezes up once the card starts acting up
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  4. #4
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Maybe trying it from grub, Highlite the grub entry to use, press e to edit, highlite the kernel line, again press e to edit. Remove all options, then add in vga=771 init=/bin/sh , then press Enter to confirm the line, then b to boot.

    If this doesn't work. your card is beyond saving. You'll have to wait for a good card (or alternatively relocate the hard drive to another computer).

  5. #5
    Just Joined!
    Join Date
    Nov 2009
    Posts
    1

    Great Tip

    Dcat

    Your post was great! I was getting clicky and screwed up my video. Your simple solution (Boot in to the recovery console. Type nano /etc/X11/xorg.conf...... ) saved the day. THANKS!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •