Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I have an Ubuntu machines and can access shares on it from Windows 2000 and XP but not windows 98. When I connect it asks for a password and when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! mpg198's Avatar
    Join Date
    Apr 2009
    Posts
    86

    Windows 98 and Ubuntu Shares


    I have an Ubuntu machines and can access shares on it from Windows 2000 and XP but not windows 98. When I connect it asks for a password and when I enter it in it says the password is incorrect, even when it is.

    I have tried everything, I enabled plain text passwords in Windows 98 but it still doesn't work. I can access Windows 2000 and XP shares, but not 98 shares.

  2. #2
    Just Joined! DaWoo's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey
    Posts
    16
    mpg198 ... I don' think you'll get too many responses on issues with Windows in this forum. Fortunately for you, I know Windows too. So, I assume you have workgroups configured. And you must have identical accounts on each box. Are you using samba? Do you have a firewall?

    What I would try is to create a user on the windows 98 box with the same username/password that you're accessing it from.

  3. #3
    Just Joined! DaWoo's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey
    Posts
    16
    I searched the internet briefly and it looks like multiple people have run into the same issue with no success. I would suggest connecting to the 98 box with rdekstop or something like VNC.

  4. #4
    Just Joined! mpg198's Avatar
    Join Date
    Apr 2009
    Posts
    86
    Why don't you think I would get many responses?

    I cannot use RDesktop or VNC, I need to share files not control the computer, and it's in a VM so I can already do that.

  5. #5
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    The problem is Win98 doesn't allow a real "Login" proceedure for SMB, it always uses the username.

    Samba has methods for dealing with this, but in essence, post 2 is correct. Samba has to have a user account with the exact spelling, case sensitive, as the Windows login name on Win98. There's a few ways of going about this.

    1. If samba is matching user accounts, create an account in Linux with the exact user name as the Windows Login.

    2. Define an Alias file, in it matching the Windows log in with an existing Linux account

    3. Change Samba to use internal authentication via a smbpasswd file, then add user accounts with
    sudo smbpasswd -a

    4. Use a different file sharing method, such as FTP.

    Okay, maybe that last one's a cop-out, but sometimes alternatives need to be considered. The following are a couple of common Samba references:

    The Official Samba 3.2.x HOWTO and Reference Guide
    Excellent since it lists examples, but is also quite large (also available as a pdf e-book)

    This is a configuration reference that's actually included in the package documentation, it lists every option and what it takes for arguements, good place to seek out specific answers:
    smb.conf

    Nobody gets Samba server configuration right the first time every time, it's just too beastly. You have to work it slow and a lot of trial and error, but you can make it work. Good Luck!

  6. #6
    Just Joined! DaWoo's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey
    Posts
    16
    Thanks D-cat .. I was trying to get there but I'm working off two hours sleep and I've been up since 3am.

    And MPG ... I said you wouldn't get that many responses because you're asking about windows on a linux forum. To me that's like asking about Honda's on a Nissan forum. But, there are definitely a few people on here that seem to be good regardless (i.e. D-Cat).

  7. #7
    Just Joined! mpg198's Avatar
    Join Date
    Apr 2009
    Posts
    86
    But Honda and Nissan are both cars and use the same road.

    I am asking about Windows and Linux, and I am sure lots of people here use Windows.

    I do have an account on Windows 98 with the same login credentials, I can connect to Windows 2000 and XP but not Ubuntu, I want to remove this stupid samba password so it all works like it's supposed to.

  8. #8
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Is this a home network? If security is not a concern (which I'm guessing since you're even using Win98), the global key

    admin users = (user)

    can quickly fix that problem. It also means that user has full access to everything.

  9. #9
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Quote Originally Posted by mpg198 View Post
    But Honda and Nissan are both cars and use the same road.
    I think in this analogy the road would be the user, but we're discussing how to get parts of their engines to work with each other

    In short, the problem lies with Windows 98. It is a 12 year old operating system and you would encounter this same problem if you were sharing out directories on any version of Windows since Windows 2000 when Active Directory was enabled. Also, bear in mind the issue of short hostnames and the path's character limit in pre-Active Directory systems.

    Have a look at this link to get you started, but I think D-Cat's answer might be what you're looking for.

    How to enable Windows 98/ME/NT clients to logon to Windows 2003 based Domains

  10. #10
    Just Joined! mpg198's Avatar
    Join Date
    Apr 2009
    Posts
    86
    Where do I put "admin users = (user)"

    In this case compatibility takes priority over security. My network has security on it anyways and I wouldn't share files I don't want people to access and I make backups in case something goes missing (or gets corrupted, accidentally deleted or whatever)

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •