Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
Originally Posted by gregoriahson My broadcom sta driver will not activate. This is the original problem i had. I click activate and the screen pauses and then nothing happens.... Sorry ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133

    Quote Originally Posted by gregoriahson View Post
    My broadcom sta driver will not activate. This is the original problem i had. I click activate and the screen pauses and then nothing happens....
    Sorry to jump in, but when you tried to activate it were you connected by network cable? The STA driver is downloaded, or rather the firmware is to activate it. I would try connecting by wire first and then running an update in Synaptic Package Manager. Then, after exiting Synaptic try System > Administration > Hardware Drivers again to try to load it. Don't forget to remove/disable ndiswrapper before trying this as waterhead said.

  2. #12
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The STA driver is the proprietary driver released by Broadcom. It is available through the linux-backports-modules megapackage. It is not just installing firmware, but the driver module too.

    As BTR said, you gotta be connected to the internet first.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #13
    Just Joined!
    Join Date
    Apr 2009
    Posts
    14
    Ok. I booted a fresh version of 9.04. Originally, when I tried to activate the STA driver (with no internet connection) nothing happened, but it said it was activated.

    I tried to do it manually with the instructions given by broadcom in the link you gave me.

    But everytime I tried to build the LKM file labled WL.KO (step 5) in my kernel it would tell me there is no such file. Even though I used `uname -r` for the kernel name.

    Then I brought the box downstairs and connected to the internet via a wired connection and updated everything. I deactivated the STA driver, then reactivated it to see if it would download. It goes to the downloading screen, but instead of downloading it sits at 0% and the progress bar goes back and forth really fast. It then exits without ever leaving 0 and says that it is active.

    In the network connections on the top right it will tell me that I am connected and give a signal strength and everything, but I cannot connect to any web pages.

    GRRRRRRRRRRR

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You don't need to build the STA driver for Ubuntu anymore. And in Jaunty, it may be installed by default.

    Is there an on/off switch for the wireless? I see that some have had to go through a specific sequence to get the wireless to work:

    1) Disable the Broadcom STA driver
    2) Reboot
    3) Use switch to turn card off
    4) Reboot
    5) Use switch to turn card on
    6) Reboot
    7) Enable the Broadcom STA driver
    8) Reboot

    It sounds dumb, but people have reported that this works.
    [ubuntu] Jaunty Broadcom (BCM4328) Wireless Problem - Ubuntu Forums
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #15
    Just Joined!
    Join Date
    Apr 2009
    Posts
    14
    As in a physical on and off switch on the card? If so no i don't think so but I'll check.

  7. #16
    Just Joined!
    Join Date
    Apr 2009
    Posts
    14
    I still don't have this card working... anyone have any ideas?

    I heard it worked on 8.10 so i might revert.

  8. #17
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Let's start over, from the beginning. Read through the sticky linked to below, an post ALL of the information that it describes how to find.

    Wireless Setup - Start Here

    I can't tell from afar just what state it is in, so this is the best way.
    Please do not send Private Messages to me with requests for help. I will not reply.

  9. #18
    Just Joined!
    Join Date
    Apr 2009
    Posts
    14
    Sorry for the delay in my response! I ended up installing 8.10 and it worked fine with the STA driver. I don't know why it wouldnt work in 9.04 but i will most likely wait for the next release before upgrading.

    Thanks for being patient waterhead if there was a rep system i would positive you!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •