Find the answer to your Linux question:
Results 1 to 10 of 10
I am very new to terminal commands and linux in general so I am looking for help in terms easy to understand thanks im on ubuntu 9.04 and I want ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    5

    tryting to install ati graphics driver


    I am very new to terminal commands and linux in general so I am looking for help in terms easy to understand thanks

    im on ubuntu 9.04 and I want to install a new up to date ati driver for my radeon HD 4870, I download the driver and look at the instructions but I need to run it as super user but the only way I can find to do that is using the confusing terminal and I can't find commands to find and install the driver. What I would like is commands to reach the diver installer in my home folder or a way I can log into as root or super user to just install this

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    STOP!

    Don't download the driver yourself, it's more work for you and you're more likely to break things - particularly during future updates.

    Check for a notification in your system tray regarding drivers. If you don't see one there go to System > Administration > Hardware Drivers and look for suggested drivers. It should tell you there is one ready to use, so just go ahead and activate it. It will download and install it automatically for you and will start working after you reboot.

    Good luck

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    5
    Thanks I have the fun eyecandy enabled now

    One Question though

    So If a new and better driver would to be released That utility would find it?

  4. #4
    Just Joined!
    Join Date
    Apr 2009
    Posts
    32
    Yes. I too am new to Ubuntu but not computers and I can say I like Ubuntu better than windows. Very Nice OS!!

  5. #5
    Just Joined! Josy's Avatar
    Join Date
    May 2009
    Posts
    3
    Hi,

    Sorry to steal the thread for a short just it is exactly what I am after.
    I am a newbie in linux and I would like to do the same - install ATI driver for my Ubuntu 9.04.
    I checked the place bigtomrodney suggested but it empty for me...
    I have the ATI driver downloaded and tried to install it following tip I found somewhere like "sh (drivername.run)" and it started but at the end it gave me the next error message:

    Error: ./default_policy.sh does not support version

    default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being

    correctly set by --iscurrentdistro

    So I stuck here because I am a complete newbiee in the linux world...
    If anybody can give some advice it would be great.
    Thank you in advance for your help.

  6. #6
    Just Joined! Josy's Avatar
    Join Date
    May 2009
    Posts
    3
    So no cure for my problem...
    Thanx to listen...

  7. #7
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    you should be able to manually install the driver using the synaptic package manager, I think it is xorg-driver-fglrx

  8. #8
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    Josy make sure that the driver you have is for your current kernel.
    to know your kernel ver. type in command
    uname -r
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  9. #9
    Just Joined!
    Join Date
    Apr 2009
    Posts
    78
    Question... in my Hardware Drivers, I am unale to activate the driver they list. When I click on activate, nothing happens. Every other method has also been unsuccesful. I've tried manual installations with no luck. Any idea why Hardware Drivers won't work? i have an ATI Radeon 4850 HD GPU.

  10. #10
    Just Joined! Josy's Avatar
    Join Date
    May 2009
    Posts
    3
    Hello there,

    Thanx mates, I will check Synaptic again and the version of my kernel.
    Unfortunately I am pretty busy later but I will post about the results.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •