Find the answer to your Linux question:
Results 1 to 5 of 5
Similar issue here. I can browse the Samba server via the SMB client command if I use the IP address, but if I use the hostname it chugs for a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    1

    times-out going to an IP address


    Similar issue here. I can browse the Samba server via the SMB client command if I use the IP address, but if I use the hostname it chugs for a while and times-out going to an IP address 24.xx.xx.xx outside my network.

    It almost sounds like the server name isn't being resolved. Do I need to create a hosts file somewhere that will resolve server names?

  2. #2
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    I haven't used samba, however here is the doc link The Official Samba 3.2.x HOWTO and Reference Guide which may help you.
    Registered Linux User #420832

  3. #3
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    first you have to run this command
    sudo apt-get install smbfs
    then edit the samba configuration file
    sudo nano /etc/samba/smb.conf
    and look for
    # Change this to the workgroup/NT-domain name your Samba server will part of
    # workgroup =WORKGROUP
    and unqute second line so it becomes
    workgroup=Workgroup
    then change it to your windows xp workgroup name for example, every xp box i have has Zaben workgroup

    then after that all what we need to do is mount the network drives

    sudo mount -t smbfs -o username=kmitnick "//192.168.2.100\D" /mnt/network
    where -t refers to type and here smbfs
    -o refers to options such as username,password then the IP address you want to connect to followed by the shared path , here D or it can be a folder X in D so it becomes 192.xxx.xxx.xxx\D\X and the last parameter is where to mount the desired shared path and here let's say /mnt/network

    but make sure you create network before runnign the command

    if you have any other question post here plz.
    enjoy
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  4. #4
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    MisterEarl you can add a host to to the hosts files
    use:

    sudo nano /etc/hosts
    sth like this will appear

    127.0.0.1 localhost
    127.0.1.1 kmitnick-laptop
    192.168.2.100 zaben-family
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    I added the third line so you can add what ever you want so if you want that if you have a wireless router having an ip 192.168.2.1 and you want to assign a name to it , all what you have to do is add the following line:
    192.168.2.1 wlan
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  5. #5
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Well, If you directly using IP, there will be no name resolution.
    You dont need samba server to connect another samba server. just samba-client is needed.
    The timeout error is more like a network error.
    Just try pinging that host.
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •