Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
i just inherited a computer with kubuntu on it. i have no experience with anything other than windows. upon turning on the computer, kubuntu comes on the screen and it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    9

    kubuntu startup


    i just inherited a computer with kubuntu on it. i have no experience with anything other than windows. upon turning on the computer, kubuntu comes on the screen and it does a drive check. unless i hit escape to skip the drive check, the screen goes to a command prompt screen. if i hit escape and skip the drive check, im able to log on and use everything. is this bad?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    upon turning on the computer, kubuntu comes on the screen and it does a drive check. unless i hit escape to skip the drive check, the screen goes to a command prompt screen.
    What message does it display at command prompt screen?
    if i hit escape and skip the drive check, im able to log on and use everything. is this bad?
    Something is wrong because none of Linux distro check disks on every boot.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    FAIL
    an automatic file system check (fsck) of the root filesystem failed. a manual fsck must be performed, then the system restarted. The fsck should be performed in maintenance mode with the root filesystem mounted in read only mode.
    (orange asterisk) Theroot file systme is currently mounted in read only mode. a maintenance shell will now be started. after performing system maintenance, press control-D to terminate the maintenance shell and restart the system.
    bash:groups: command not found
    bash: lesspipe: command not found
    bash: command: command not found
    bash: the: command not found
    bash:dircolors: command not found
    bash: command: command not found
    bash: the: command not found
    root@dannystoy:~#

  4. #4
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    I'm inclined to agree with Casper. If you let fsck (File System ChecK, Linux version of Scandisk) finish on its own and it drops to a prompt, it likely failed the check. Check the screen and see if there are any messages directly following the fsck that would indicate what problem was found (and often what to do about it).

    In cases where a severe error was found (like a bad sector), the fsck from boot will not automatically fix it for fear of data loss. You'll need to manually invoke it with option to fix everything. This is best done form a drive you did not boot from (another reason for not auto-fixing severe errors), suggested is to boot from a live CD, then run fsck against the hard drive from the CD boot. It's not a requirement*, it's just safer.

    I'm sorry you inherited this mess. Doing this operation from Linux actually isn't much different than doing it from MS-DOS, but I know that's little comfort to those used only to Windows XP and later. We are here to explain how to do what you need to make this thing work again.

    *Though it is not a requirement that you run fsck from a different drive, it is a requirement that any drive you run fsck with fix errors on must not be mounted with read/write permissions. While preferred that it's run on a disk that's not mounted at all, if you must invoke from that hard drive, you can get away with it if it is mounted read-only. At least this way, the system will not be writing data to the drive while it's trying to fix it (which could easily cause corruption if it did).

    p.s. If indeed the error is a bad sector/cluster/block, the computer would be best served to replace the hard drive as soon as you are able. Failing blocks tend to have a domino effect.

    ---


    Edit: You were answering as I wrote my reply. I'll answer in next post. Sorry.

  5. #5
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    In order to determine the correct drive to run fsck on, please type fdisk -l (that's FDISK -L in lower case) and post the output.
    edit: I just realized, your being in a maintenance shell means that environment variables may not be set. Translation, you may have to type it as /sbin/fdisk -l
    At least you're already mounted read-only, work can proceed.


    ---

    for my own reference:

    fsck.ext3 -ckfvy {device}

    This means scan "device" with an "ext" file system
    check for physical errors (this can take a while)
    keep: save any known or found bad blocks
    force the check (probably redundant)
    verbose: show me what's being done
    assume yes to prompts

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of /etc/fstab file here.
    Code:
    cat /etc/fstab
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    i entered /sbin/fdisk -l

    disk /dev/sda: 80.0 GB, 80060424192 bytes
    255 heads, 63 sectors/track, 9733 cylinders
    units = cylinders of 16065 * 512 = 8225280 bytes
    disk identifier: 0x308fa837

    device boot start end blocks Id System
    /dev/sda1 * 1 9463 76011516 83 linux
    /dev/sda2 9464 9733 2168775 5 extended
    /dev/sda5 9464 9733 2168743+ 82 linux swap / solaris

    then i entered cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda1
    UUID=95958d28-0d46-4999-86ff-a172a4a15236 / ext3 relatime,error
    s=remoun-ro 0 1
    # /dev/sda5
    UUID=89311b76-6817-4273-bca0-d2f28bc5fc50 none swap sw
    0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user, noauto, exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    sudo nano /etc/fstab
    Replace 1 with 0 ( zero ) in first UUID line.
    Code:
    UUID=95958d28-0d46-4999-86ff-a172a4a15236 / ext3 relatime,errors=remount-ro 0 0
    Press Ctrl+X, Y and hit Enter key to save file.

    This will disable fsck and if it works, I would suggest you to check your Hard disk through tools provided by your Hard disk Manufacturer. It looks like your hard disk is dieing.


    How do you shutdown your machine?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    I believe you should still do the

    /sbin/fsck.ext3 -ckfvy /dev/sda1

    while in read-only (or booted from live CD - DO NOT RUN THAT COMMAND IN USER MODE!) prior to continuing to use this drive. If a preened fsck is failing, the likelihood of data loss and/or system crashing is high until the bad spots are marked and the file system repaired. The policy of ignoring the error is folly, and low level tools will not repair the fs, only (hopefully) prevent further damage.

    To put it another way, your CO alarm goes off in the night, do you clear house then try to find why it's going off and fix the problem, or, do you unplug it so you can continue to sleep?

  10. #10
    Just Joined!
    Join Date
    May 2009
    Posts
    9
    i entered the command: sudo nano /etc/fstab
    response:
    Command 'sudo' is available in '/usr/bin/sudo'
    The command could not be located because '/usr/bin' is not included in the PATH environment variable.
    bash: sudo: command not found

    i always turn off the computer by choosing the shutdown option

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •