Find the answer to your Linux question:
Results 1 to 7 of 7
I have a lil annoyance with boot up and my display/refresh rate settings. Well right from the get go before the propriety drivers were installed I could set and boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Frylock2009's Avatar
    Join Date
    Apr 2009
    Posts
    32

    nvidia settings


    I have a lil annoyance with boot up and my display/refresh rate settings. Well right from the get go before the propriety drivers were installed I could set and boot x with 1024x768, 80 refresh but after propriety drivers only 800x600 was available. So I have to manually set nvidia to desired display and res at boot up every time, of course my twin view as well. Apparently I cannot save nvidia settings to xconf, Had many issues when I tried that. Is there a way to save nvidia configuration and load it at boot up in sessions?

    Btw...Running Ubuntu jaunty jackalope 9.4 with XFCE d.m

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of /etc/X11/xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Apparently I cannot save nvidia settings to xconf, Had many issues when I tried that. Is there a way to save nvidia configuration and load it at boot up in sessions?
    Are you opening nvidia-settings with root privileges? Hit ALT+F2 and type gksudo nvidia-settings to do so.

  4. #4
    Just Joined! Frylock2009's Avatar
    Join Date
    Apr 2009
    Posts
    32
    yes I have saved to x wit "sudo nvidia-settings" before. But from what I understand nvidia and x do not play well together, also from personal experience. When I save nvidia settings to x, whenever I restart x It messes with rendering..say like cairo-dock...cant see anything but white where its supposed to be, applets nothing but a white box and so on. Is there a script I can create to load nvidia settings separately from x?

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection

  5. #5
    Just Joined! Frylock2009's Avatar
    Join Date
    Apr 2009
    Posts
    32
    Ok, I stand corrected, The team must have fixed the issue with nvidia and xorg, I ended up trying to save nvidia settings to xorg.conf restarted x and everything is great.

    (edit) I spoke to soon....I cant get no window borders and some windows (terminal) for one is completely white and cannot see nothing I type...
    Here's the nvidia generated config merged with xorg.conf...

    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "HP MX50"
    HorizSync 30.0 - 54.0
    VertRefresh 47.0 - 100.0
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce4 MX 440 with AGP8X"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "CRT: 1024x768 +0+0, TV: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

  6. #6
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,569
    The only differences (apart from diferent cards) that I can see in my xorg.conf is that I have both of these set in mine

    Option "TwinView" "1"
    Option "Xinerama" "1"

    so try changing

    Code:
    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "CRT: 1024x768 +0+0, TV: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    to

    Code:
    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option         "Xinerama" "1"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "CRT: 1024x768 +0+0, TV: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    Mine works flawlessly across multiple monitors using nvidia. I even get a single desktop cube across the monitors which looks ridiculously cool!
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  7. #7
    Just Joined! Frylock2009's Avatar
    Join Date
    Apr 2009
    Posts
    32
    I don't get it...

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Xinerama" "1"
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "CRT-0"
    Option "metamodes" "CRT: 1024x768 +0+0, TV: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    No change, still no window border and as far as I can tell (so far) its only the terminal windows that opens as a white box. Any suggestions on what I can change here would be great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •