Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Hal343 is correct, the ath5k driver should work. I believe, though, that it's included in Ubuntu 9.04. It's not loading in your setup, though, but ndiswrapper is. There are some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651

    Hal343 is correct, the ath5k driver should work. I believe, though, that it's included in Ubuntu 9.04. It's not loading in your setup, though, but ndiswrapper is. There are some other drivers that also can interfere with ath5k, so we need to make sure they are all blacklisted.

    Press ALT+F2 and type gksudo gedit /etc/modprobe.d/blacklist

    Add this to the end of the file and save.
    Code:
    blacklist ath_hal
    blacklist ath_pci
    blacklist ndiswrapper
    blacklist ath_hal and blacklist ath_pci may already be in there.

    Now make sure the right driver is loading.
    Press ALT+F2 and type gksudo gedit /etc/modules
    and add
    Code:
    ath5k
    to the end of the file, then save.

    This should make it load the right driver on reboot.

    Without rebooting, you can also do
    Code:
    sudo modprobe -r ndiswrapper
    sudo modprobe ath5k
    sudo ifconfig wlan0 up
    And see if your wireless is working.

  2. #12
    Just Joined!
    Join Date
    May 2009
    Posts
    5
    Quote Originally Posted by reed9 View Post
    Hal343 is correct, the ath5k driver should work. I believe, though, that it's included in Ubuntu 9.04. It's not loading in your setup, though, but ndiswrapper is. There are some other drivers that also can interfere with ath5k, so we need to make sure they are all blacklisted.

    Press ALT+F2 and type gksudo gedit /etc/modprobe.d/blacklist

    Add this to the end of the file and save.
    Code:
    blacklist ath_hal
    blacklist ath_pci
    blacklist ndiswrapper
    blacklist ath_hal and blacklist ath_pci may already be in there.

    Now make sure the right driver is loading.
    Press ALT+F2 and type gksudo gedit /etc/modules
    and add
    Code:
    ath5k
    to the end of the file, then save.

    This should make it load the right driver on reboot.

    Without rebooting, you can also do
    Code:
    sudo modprobe -r ndiswrapper
    sudo modprobe ath5k
    sudo ifconfig wlan0 up
    And see if your wireless is working.
    HA! That did it! nk you so much, everyone who helped

  3. #13
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    I think I know the problem already. When you installed ndiswrapper did you follow online instructions that told you to blacklist your native driver? If so, did you remember to unblacklist it when I told you to get rid of ndiswrapper or did you just remove ndis and forget to go into your modprobe.d/blacklist file?
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    i just installed Ubuntu 9.04 on my Eee PC 900, and it has the same wireless. I then updated it.

    The wireless worked out-of -the box. But after installing a program to enable the Function (Fn) keys, and then testing the wireless on/off keys, I had to reboot. When i checked the output of lsmod, I found that it was loading both the ath5k and ath_pci modules! I never enabled the madwifi (ath_pci) driver, so maybe it was the Funtion keys program that did this.

    This may not apply here, but it may be something to keep an eye out for.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •