Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
My computer just started to lag and run slow. This only started after I executed "dpkg-reconfigure xserver-xorg" to fix the monitor "out of range problem" on my game. I didn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    6

    Running Slow


    My computer just started to lag and run slow. This only started after I executed "dpkg-reconfigure xserver-xorg" to fix the monitor "out of range problem" on my game. I didn't actually change any variables (I was only able to reconfigure my keyboard) but I somehow fixed the "out of range" problem" at the same time making my computer slow and laggy. None of the desktop effects of comiz work any more (before they did), I also lost the window border and the ability to minimize/maximize when in compiz. I am wondering if there is a way to fix any of the problems I am facing. I fairly inept at Linux so any help is appreciated.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    I think your changed your video card driver, when you used the above command. Can you post the output of these terminal commands please?
    Code:
    sudo lspci |grep VGA
    Code:
    sudo cat /etc/X11/xorg.conf
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    I got

    01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

    and

    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    Option "UseFBDev" "true"

    Section "Monitor"
    Identifier "Configured Monitor"

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You haven't installed Nvidia Proprietary driver. Install it through Hardware Drivers option available in Administrative Menu.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    That fixed the lag problem but now I have the "out of range problem" when I try to run my game. I know it has something do with my monitor not reading the frequency of the game but how to I change the variables so it does allow the game to function normally?

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    What game are you playing? Are you using WINE or Cedega to run it?
    Do you have the manual that came with your Monitor, so you can set the correct hsync and vsync settings? If you do, then you can try adding the setting to the /etc/X11/Xorg.conf file. Here is what mine looks like, so you can reference it.
    Code:
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "HP Pavilion"
        ModelName      "HP MX50"
        HorizSync       30.0 - 54.0
        VertRefresh     47.0 - 100.0
    EndSection
    You'll need to change the highlighted entries to match the correct settings in your manual. The identifier needs to be left alone, but you can change Vendorname to match the name of the monitor mfg, the model name can be anything you want to call it. Let us know if this helps any.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You might also try commenting out the Option "UseFBDev" "true" line.
    Just put a # front of it
    #Option "UseFBDev" "true"
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #8
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    When I edited /etc/X11/xorg.conf I didn't have anything under the monitor section besides identifier so added the the information you posted, but nothing happened, my monitor is not supposed to go above 75Hz so I set that the maximum then tried some other numbers to see if they worked but no luck. Commenting out the Option "UseFBDev" "true" line didnt work either.

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try this
    Code:
    HorizSync       30.0 -  70.0
    VertRefresh     50.0 - 160.0
    In case it doesn't work, post the contents of xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #10
    Just Joined!
    Join Date
    May 2009
    Posts
    6
    My original xorg.conf file looks like this
    Code:
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	DefaultDepth	24
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Option		"UseFBDev"		"true"
    	Driver	"nvidia"
    EndSection
    I added HorizSync 30.0 - 70.0 and VertRefresh 50.0 - 160.0 underneath identifier so
    Code:
    Section "Monitor"
    	Identifier	"Configured Monitor"
    	HorizSync       30.0 -  70.0
    	VertRefresh     50.0 - 160.0
    EndSection
    But nothing happened

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •