Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
The IP is there, so you should be able to make IP based connections, I think, but to make DNS connections you also need to fill in the IP of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast Bemk's Avatar
    Join Date
    Sep 2008
    Location
    Oosterhout-NB, Netherlands
    Posts
    525

    The IP is there, so you should be able to make IP based connections, I think, but to make DNS connections you also need to fill in the IP of the DNS.

  2. #12
    Just Joined!
    Join Date
    Feb 2007
    Posts
    32
    but every time i restart the system the network connection is showing disconnected.....

    for to get the network access i need to set the ip manually in each time .....

    it is the problem ....................

  3. #13
    Linux Enthusiast Bemk's Avatar
    Join Date
    Sep 2008
    Location
    Oosterhout-NB, Netherlands
    Posts
    525
    have you tried setting the static in '/etc/networking/interfaces'? If not you should try.
    If it doesn't solve it, try disabling avahi and setting the static in the same file as mentioned before.

    I think that should do the trick.

  4. #14
    Just Joined!
    Join Date
    Feb 2007
    Posts
    32
    i have seen this two lines only in the "/etc/network/interfaces "
    ..........................
    auto lo
    iface lo inet loopback
    ..........................

    and how to set the static in interfaces file?

    waht is avahi ?

    how to disable the avahi ?

    need help.............

  5. #15
    Linux Enthusiast Bemk's Avatar
    Join Date
    Sep 2008
    Location
    Oosterhout-NB, Netherlands
    Posts
    525
    Avahi takes care of network settings on boot and in runtime, if you disable it, the IP will remain as it is, but you do have to set the configuration files.

    My interfaces file looks like this:
    Code:
    auto eth0
    iface eth0 inet static
            address 192.168.*.*
            netmask 255.255.255.0
            network 192.168.*.0
            gateway 192.168.*.*
    In the /etc/resolv.conf you van set the dns settings. You will also need to set those.
    Code:
    nameserver *.*.*.*
    I think it's obvious what's supposed to go on the places masked with *.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •