Find the answer to your Linux question:
Results 1 to 3 of 3
I am a brand new ubuntu user so I don't really know how to do anything, so thanks in advance for your patience. I have the fairly common problem of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    2

    Headphone Jack and Internal Speakers Problem


    I am a brand new ubuntu user so I don't really know how to do anything, so thanks in advance for your patience.

    I have the fairly common problem of my headphone jack not working. Sound only plays out of my laptops built in speakers even when headphones are plugged in. It shouldnt be a defective jack, because it works in windows still.

    I've tried right clicking the speaker icon in the top right and going
    >volume control but there is no "switches" tab and thus I dont see the headphone jack sense option box or anything like that. I only see tabs for playback and sound theme. There is a button on the bottom that says preferences. when i click that the only options are two check boxes: one for Master and one for PCM. The device drop down at the top of the volume control window says I am using HDA Intel (Alsa Mixer); there are three other options. The second option is sigmatel (oss mixer).

    With windows, my audio drivers are called sigmatel something. I've tried this second option but it makes no difference.

    I have a sony laptop sz650nc if that helps

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Check out the Ubuntu documentation for sound troubleshooting.

    I'm going to take a wild guess that the sigmatel something is the STAC9205. I have a laptop with this, and I have yet to get the headphones to work. It's a known bug. It worked back in kernel version 2.6.24, and hasn't since.

    EDIT: Huh, I haven't looked into this for awhile, but it seems there may be a fix.
    [all variants] ALSA Upgrade Script - Ubuntu Forums

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    2
    its similar but not the same letters exactly

    I registered at that forum and downloaded the files, but im afraid i dont understand the instructions at all. I have no idea how to use the console or bring it up.

    Short Alsa-Upgrade script install instructions:
    1. download the script and save it somewhere
    2. cd <your-download-dir>
    3. tar xvf AlsaUpgrade-1.0.x-rev-1.17.tar
    4. sudo ./AlsaUpgrade-1.0.x-rev-1.17.sh

    (The same way you'll handle the uxchecker-1.0x.tar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •