Find the answer to your Linux question:
Results 1 to 7 of 7
Hey all, I have looked over the web and discovered ways to disable that annoying system beep I get whenever I accidently press the backspace key to many times or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    32

    Change File Permissions - Annoying System Beep


    Hey all,

    I have looked over the web and discovered ways to disable that annoying system beep I get whenever I accidently press the backspace key to many times or move too many keys around in text editors.

    I know that for a temporary fix, I simply open up Terminal and type: "sudo rmmod pcspkr"

    However, for a permanent change, I need to edit /etc/modprobe.d/blacklist and add the line, "blacklist pcspkr" and save it.

    However, this is where I hit a problem.

    When I try to add the line "blacklist pcspkr" and save the .conf file, I get an error saying: "You do not have the permissions necessary to save the file. Please check that you typed the location correct and try again."

    My goal is to permanently turn off the system beep. However, I cannot edit my blacklist.conf file due to complications with permissions.

    Can anyone help me with what I am trying to do? Thank you.

  2. #2
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    you need to run as root
    use
    Code:
    sudo nano /etc/modprobe.d/blacklist
    and add the line
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I feel like Ubuntu doesn't have nano installed by default? Could be wrong. But in case you run into an error, you an replace nano with the text editor of your choice. (Nano is just a command line text editor.) If you want a graphical text editor, Ubuntu has gedit installed by default. Same process:

    Code:
    sudo gedit /etc/modprobe.d/blacklist
    or alternately press ALT+F2 and type gksudo gedit, to open gedit with root permissions.

  4. #4
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    thnx reed9 for your reply
    but don't worry nano is installed by default but he may face a littleeeeeeee problem with command line
    so gedit is better at the moment

    anyway sudo is the key word to do the trick
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  5. #5
    Linux Newbie egan's Avatar
    Join Date
    Feb 2009
    Location
    Mountain View, CA
    Posts
    132
    Hmm, I always hated that "feature" as well. I had to blacklist it. It's not like I didn't want the beep, I just didn't want it to go off all the time. If you want to disable the beeping but not the beep itself, try:
    System>Preferences>Sound>Sounds and disable "Play alert sound".

  6. #6
    Just Joined!
    Join Date
    May 2009
    Posts
    32
    Quote Originally Posted by egan View Post
    Hmm, I always hated that "feature" as well. I had to blacklist it. It's not like I didn't want the beep, I just didn't want it to go off all the time. If you want to disable the beeping but not the beep itself, try:
    System>Preferences>Sound>Sounds and disable "Play alert sound".
    Egan, will doing what you suggested keep the beeping sound off, even if I reboot my machine?

  7. #7
    Linux Newbie egan's Avatar
    Join Date
    Feb 2009
    Location
    Mountain View, CA
    Posts
    132
    Quote Originally Posted by Rarehunter View Post
    Egan, will doing what you suggested keep the beeping sound off, even if I reboot my machine?
    It should. It will only stop the beeping itself not the actual device, so you can still receive a beep on the terminal when echoing a ^G character.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •