Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Sitting here around with my 2 Usb Sticks... Want to Copy 200Mb on it...40 Minutes to wait... I dont know what to do anymore...in the past there were solutions like ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    18

    All Usb Sticks are soooooo slow


    Sitting here around with my 2 Usb Sticks... Want to Copy 200Mb on it...40 Minutes to wait...

    I dont know what to do anymore...in the past there were solutions like deactivating sycing etc.
    but now i dont want to accept it any more.

    My Hardware is 2 Usb 2.0 Sticks and Usb 2.0 on my Toschiba book from Spring 2009.

    Aftrer 2 Minutes the rate is at 50Kbs , still going down... In widows at university sticks work with 11MB per second... so its an ubutu Problem, or linux at all... because in Fedora sticks only work with 1,5 Mb...

    Old Tricks like, deactivate sync in fstab dont work anymore, because sync isnt in it anymore...deactivating old uhci modules. etc. doesnt work too, because those modules are not there any more..

    PLEASE POWER UP MY DRIVES

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    18
    no one an idea ?i dont think iam the only one with that problem...

  3. #3
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    can you post the output of
    Code:
    /etc/fstab
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    of before that try this out

    right click on the device icon on the desktop, select "Preferences", select the "Mounting" tab, and uncheck "Synchronous". This setting seems to stick for future mounts of the device.
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  6. #5
    Just Joined!
    Join Date
    May 2009
    Posts
    18
    Okay, Stick is Plugged in :

    1: Fstab :

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # / was on /dev/sda1 during installation
    UUID=4fa6ff3c-1f15-4322-9abd-27c2d5005d84 / ext4 relatime,errors=remount-ro 0 1
    # /HDD2 was on /dev/sda6 during installation
    UUID=efd93c99-974e-41dd-8333-f66cd47f75c7 /HDD2 ext3 relatime 0 2
    # swap was on /dev/sda5 during installation
    UUID=1534d6a6-ce2b-4023-87da-c8278882f82c none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

    In Fstab isnt an entry 4 That Stick.


    2. Method :

    Theres no Option like "mount" etc. even theres no option to change anythin about the stick...
    Never had those ones...Thats the Problem, i never find sth. in my system about the old sysnc. options... And up to that settings, the stick stays slow for 1,5 years....



    And thaths the Problem, all the "old tricks" dont work anymore, and now its horrible to work with linux and Usb Sticks... I

    In the attachment u See the Volume Tab, its in German, but the main things u can read and understand
    Attached Images Attached Images

  7. #6
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    I am not sure if this is gonna work but let's give a shot.

    press Alt+F2 then type gnome-terminal
    Edited:BEFORE RUNNING THIS POST THE OUTOUT OF
    Code:
    ls /dev | grep sd

    DO NOT RUN THIS NOW
    Code:
    sudo nano /etc/fstab
    add this line to the end of it Assuming your flash device is /dev/sdb
    Code:
    /dev/sdb1 /media/disk vfat user,auto,sync 0 0
    press Ctrl+X and then type y and press enter and plug the usb stick in.

    waiting for your reply
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  8. #7
    Just Joined!
    Join Date
    May 2009
    Posts
    18
    root@LinuxOS:~# ls /dev | grep sd
    sda
    sda1
    sda2
    sda5
    sda6
    sdb
    sdb1

    OKay done, i think your mainidea was to override automatic, and made it manual in the fstab.,..

    With sync option : 25Kb /s, without 128Kb /s falling to 50Kb /s

    that isnt a solution

    Tested in Windows on the Pc of my Colleque, 8Mb/s stick one (our test stick here)
    the Toshiba stick 11Mb/s...

  9. #8
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    do you have the same speed if you mount the device manually with root previliges???

    first unmount
    then
    Code:
    sudo mount /dev/sdb1 /media/disk
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  10. #9
    Just Joined!
    Join Date
    May 2009
    Posts
    18
    iam root, so yes previleges are given

  11. #10
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    so is it faster ??
    and you have root privs. but can't use them unless you type the sudo before the command, no one under ubuntu can enter as root unless using sudo or su - commands,
    btw try async instead of sync then type mount -a Note:do not remove usb flash until you unmount it first
    good luck
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •