Find the answer to your Linux question:
Results 1 to 7 of 7
Hi All, I noticed last week that my number keys (not the ones on top but the second set that requires the push of fn+#) stopped working. I then just ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998

    [SOLVED] keys stopped functioning


    Hi All,

    I noticed last week that my number keys (not the ones on top but the second set that requires the push of fn+#) stopped working. I then just noticed that my numbers on my external USB keyboard also don't work. Pressing num lock does nothing.

    Any ideas how to fix this? I use them for work so having them off is troublesome to say the least Thanks all
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  2. #2
    Linux User kmitnick's Avatar
    Join Date
    May 2008
    Location
    Jordan - Amman
    Posts
    329
    can you post the content of
    /etc/X11/xorg.conf
    Dual Booting Ubuntu 10.04, Windows 7

    Toshiba Satellite A200-1M5, Duo Core 2.0 Ghz, 1 Gigs RAM, 256 Intel Card

    You are registered Linux user number 490788
    Happy Linuxing

  3. #3
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildd@palmer) Mon Nov 3 08:46:46 UTC 2008

    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Gateway FPD2185W"
    HorizSync 31.0 - 81.0
    VertRefresh 56.0 - 76.0
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce Go 7900 GS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
    DefaultDepth 24
    EndSection

    Section "Screen"

    # Removed Option "TwinView" "0"
    # Removed Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "DFP-0: 1680x1050 +0+0, DFP-1: nvidia-auto-select +1680+0"
    # Removed Option "metamodes" "DFP-0: 1680x1050 +0+0"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinViewXineramaInfoOrder" "DFP-0"
    Option "TwinView" "0"
    Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  4. #4
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,559
    Does your keyboard have a key marked F-Lock? If so push it and see if that fixes it.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  5. #5
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    Okay so I've pinpointed it more:

    elija -- F-lock does nothing

    It's user specific so it must be something in my home folder. I created a test user and the keys work no problem. So my question now....what do I do? It must be in some config file but I don't want to just start randomly guessing which one. Thanks all
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  6. #6
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    Could you use the new user to read /var/log for error messages?
    Registered Linux User #420832

  7. #7
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    I ended up brute forcing it. Needed to get it working so I deleted a ton of config files....lost my setup for quite a few things so I spent a lot of time last night getting it all back together. I wish I had the time to figure out exactly what happened but I just needed it to work for work purposes. Thanks all!
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •