Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Ok, gonna try either using the Ubuntu recovery mode, which seemed to work for someone over at Ubuntu forums.org (/showthread.php?t=313600 - not allowed to post links yet.) or try reinstalling ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jun 2009
    Posts
    16

    Ok, gonna try either using the Ubuntu recovery mode, which seemed to work for someone over at Ubuntu forums.org (/showthread.php?t=313600 - not allowed to post links yet.) or try reinstalling GRUB, also suggested. We'll see how that goes...

  2. #12
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I think what needs to happen now is you need to edit grub to reflect the changes you have made by switching the boot order.
    Boot up a Live CD and mount the Ubuntu root partition and then post a copy of /boot/grub/menu.lst. You also need to post the output of
    fdisk -l

    Unfortunatly I will be gone for several hours or maybe longer. If anyone is following along, please do help out.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #13
    Just Joined!
    Join Date
    Jun 2009
    Posts
    16
    Alas, it seems the HD switch didn't actually solve the problem - I get the same error when trying to boot using the LiveCD. Nor does the disk have a recovery mode.

    This seems to indicate the problem isn't actually with labelling of the drives - surely the liveCD should label them as it sees them, rather than as they're listed on the HD's GRUB.

    Thanks for the help MikeTbob, hopefully it'll help me on my way at least.

  4. #14
    Just Joined!
    Join Date
    Jun 2009
    Posts
    16
    Ok, well, eventually (after trying a lot more things i'm not gonna go into here, i have like 5 threads on this on various forums, search for those if you're having the same problem and want some other things to try) I backed up everything off the drive onto DVD (took a while on a 160GB drive!), tried to format it, although windows wasn't having it, and ground to a halt half-way through. Possibly it was the drive after all that. Eventually I split the drive into two, managed to format one in windows, and the other in linux. Couldn't format it using as ntfs using mkfs -t ntfs, getting a mfks.ntfs not found error, so ended up formatting it as a linux partition. And, after a few disk checks, it seems to have worked. Not an ideal solution, as 70GB of my HD is now accessible only to linux, but it's good enough. Solved, of a fashion.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •