Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I'm trying to record in audacity from a microphone, (on the desktop) but nothing seems to be recording. The mic is good (checked it out on another machine). I've ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    jwf
    jwf is offline
    Linux Newbie jwf's Avatar
    Join Date
    Mar 2005
    Location
    Ontario, Canada
    Posts
    187

    microphone input fails


    Hi,
    I'm trying to record in audacity from a microphone, (on the desktop) but nothing seems to be recording. The mic is good (checked it out on another machine).
    I've searched the forums and have opened alsamixer and un-muted the microphone everywhere I see that control but still nothing records in audacity or sound recorder.
    Audacity plays back OK because i can generate some effects in some tracks, but turning on microphone monitor shows nothing coming through the mic .
    Anyone have an idea what I can try?
    Ubuntu 11.04 on IBM ThinkCentre
    Fedora, VMware Player (windows xp,Knoppix 6.5) on Lenovo Laptop
    GRUB Fedora / Windows 7, VMware Player (Windows 2008 server) on NCIX quad core PC.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,578
    Is your sound card built into the motherboard, or are you using an add-in card? If an add-in, it is possible that the system isn't sure which input channel (built-in vs. sound card) to use.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    jwf
    jwf is offline
    Linux Newbie jwf's Avatar
    Join Date
    Mar 2005
    Location
    Ontario, Canada
    Posts
    187
    I think the sound card is built in to the mother board.
    If I go to System>Preferences>Sound, I try all the selections under "Audio Conferencing Sound Capture" (I figure this should be the microphone) there are about 10 selections, one of which is "Test Sound" this is the only one of the selections that produce a sound (not a very good one though) when tested. I don't know if this has anything to do with my problem. I figure one of the other selections (Intel ICH6 with AD1981B Intel ICH6 - Mic2 ADC (ALSA) )should produce something. Maybe I'm barking up the wrong tree here??

    update:this may be significant, Audacity does not show any device selection toolbar even though I selected it to be on.
    Maybe this suggests that the hardware is having trouble identifying an input device.
    Ubuntu 11.04 on IBM ThinkCentre
    Fedora, VMware Player (windows xp,Knoppix 6.5) on Lenovo Laptop
    GRUB Fedora / Windows 7, VMware Player (Windows 2008 server) on NCIX quad core PC.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,578
    Have you tried installing Skype and seeing if it can find it? I have found that Skype is pretty good about seeing all the audio hardware in the system, even my bluetooth headset.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    jwf
    jwf is offline
    Linux Newbie jwf's Avatar
    Join Date
    Mar 2005
    Location
    Ontario, Canada
    Posts
    187
    Skype is installed, But I've only used it as a chat.
    Testing it now, I get an error message that says "Problem with audio playback"

    update: going to System>Administration>Hardware Testing verifies my sound playback works fine. The audio card detected is ICH6.
    Ubuntu 11.04 on IBM ThinkCentre
    Fedora, VMware Player (windows xp,Knoppix 6.5) on Lenovo Laptop
    GRUB Fedora / Windows 7, VMware Player (Windows 2008 server) on NCIX quad core PC.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,578
    Go to the Skype options->audio devices form. There is a combo box for audio output and input that should recognize the devices on the system. You will probably need to change them from "default".
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    jwf
    jwf is offline
    Linux Newbie jwf's Avatar
    Join Date
    Mar 2005
    Location
    Ontario, Canada
    Posts
    187

    solved!

    Hmm, seems this machine has two places to plug in a microphone, on the back and on the front. I switched to the front jack and it now works fine.

    Thanks for your help Rubberman.
    Ubuntu 11.04 on IBM ThinkCentre
    Fedora, VMware Player (windows xp,Knoppix 6.5) on Lenovo Laptop
    GRUB Fedora / Windows 7, VMware Player (Windows 2008 server) on NCIX quad core PC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •