Find the answer to your Linux question:
Results 1 to 10 of 10
Hi! I finally found the following 'boot.ini' line: c:\wubildr.mbr="Ubuntu" I tried to delete this line in order to get rid of the dual boot window at startup. However, when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7

    How do I delete the following line: c:\wubildr.mbr="Ubuntu"


    Hi!

    I finally found the following 'boot.ini' line:

    c:\wubildr.mbr="Ubuntu"

    I tried to delete this line in order to get rid of the dual boot window at startup. However, when I tried to delete this line, I got a popup window that said 'access
    denied'. How can I delete the above line and then save the new 'boot.ini' file?

    Also, I saw at the top of the notepad window that there was a line that said:
    'timeout=15'. Is this the time that it takes for the computer to turn off, and if so,
    can I lower the value so that the computer turns off faster? Thanks!

  2. #2
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Quote Originally Posted by sashag View Post
    Hi!

    I finally found the following 'boot.ini' line:

    c:\wubildr.mbr="Ubuntu"

    I tried to delete this line in order to get rid of the dual boot window at startup. However, when I tried to delete this line, I got a popup window that said 'access
    denied'. How can I delete the above line and then save the new 'boot.ini' file?

    Also, I saw at the top of the notepad window that there was a line that said:
    'timeout=15'. Is this the time that it takes for the computer to turn off, and if so,
    can I lower the value so that the computer turns off faster? Thanks!
    Be careful! Deleting lines in that file may stop your computer from booting at all!

    The timeout=15 setting is the time in seconds that it shows your grub (the options of operating systems) before choosing the first option on the list.
    Linux User #453176

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    72
    Not fully sure, but I think you installed ubuntu using wubi on windows. That file is created by that. Remove ubuntu from add/remove programs, the file should disappear on its own.

  4. #4
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    Quote Originally Posted by thinkfree View Post
    Not fully sure, but I think you installed ubuntu using wubi on windows. That file is created by that. Remove ubuntu from add/remove programs, the file should disappear on its own.
    I have already 'deleted' or uninstalled the Ubuntu OS from within Windows using the add remove program. I thought that this would get rid of the dual boot startup
    window, but it didn't. Now, I'm stuck with the dual boot window at startup, and don't know how to get rid of it so that my computer only starts up in Windows. As mentioned by a few other people, a lot of different things have been suggested, but
    at my level of expertise with Linux, the easiest idea was the removal of the wubi
    line. Since I can't delete this line, I don't know what else to do other then scrubbing
    my drive and reinstalling Windows. I'd hate to have to do this as I would then also
    have to reinstall my sound, which was even harder to do! Any other simple suggestions? Thanks!

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    72
    If you can't find another solution, you can try this(Haven't tried myself)
    Open your BOOT.INI file. It will be like
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOW S
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Micro soft Windows XP Home Edition" /fastdetect /NoExecute=OptIn
    c:\wubildr.mbr="Ubuntu"
    Remove C:\wubildr.mbr........ line from that.
    If you are able to reboot, then it's fine. Else restore windows bootloader using XP install cd . You won't have to reinstall whole OS.

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,115
    Hopefully when you used Windows Add/Remove Programs (which was the incorrect way to uninstall a wubi Ubuntu install by the way) that it botched the job. It looks like it did by leaving the boot entry behind.

    Right click your start button in Windows and choose explore. Find the Ubuntu folder in programs or whever it was put in C drive. (I don't run wubi or Windows, so I can't say exactly where it is.) Inside of Ubuntu folder it a uninstall icon. That was what you should have used to uninstall wubi. Not Add/Remove. Double Left click icon. Hopefully not everything is too borked by
    add/remove. That uninstaller should fix your ini. entry hopefully.

    Edit: If that doesn't work for ya. Before I would do a Windows reinstall. I would download wubi again and reinstall Ubuntu as a fresh wubi install. Then I would use the uninstaller icon in Ubuntus folder like I stated above. That way you know all the components for uninstalling Ubuntu wubi are present since maybe add/remove might have deleted some uninstall components that came with uninstaller.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  7. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The powers of google to the rescue.

    How to edit the Boot.ini file in Windows XP

  8. #8
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    It may fail to edit if for some reason Windows thinks the file is in use by another application. Fixing this means editing the file outside of Windows, either with a Linux LiveCD, or you can use a Windows based BartPE CD such as UBCD for Windows .

  9. #9
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    Quote Originally Posted by rokytnji View Post
    Hopefully when you used Windows Add/Remove Programs (which was the incorrect way to uninstall a wubi Ubuntu install by the way) that it botched the job. It looks like it did by leaving the boot entry behind.

    Right click your start button in Windows and choose explore. Find the Ubuntu folder in programs or whever it was put in C drive. (I don't run wubi or Windows, so I can't say exactly where it is.) Inside of Ubuntu folder it a uninstall icon. That was what you should have used to uninstall wubi. Not Add/Remove. Double Left click icon. Hopefully not everything is too borked by
    add/remove. That uninstaller should fix your ini. entry hopefully.

    Edit: If that doesn't work for ya. Before I would do a Windows reinstall. I would download wubi again and reinstall Ubuntu as a fresh wubi install. Then I would use the uninstaller icon in Ubuntus folder like I stated above. That way you know all the components for uninstalling Ubuntu wubi are present since maybe add/remove might have deleted some uninstall components that came with uninstaller.
    I reinstalled Ubuntu and then I used the uninstaller icon in Ubuntu. However, when I booted up the computer again, I still had the dual boot window show up.
    When I clicked on the Ubuntu boot option, I got the error message that the following file was missing: system32\hal\dll. The error message said that I needed to reinstall this file in order to make the Ubuntu startup work. Is this the reason I can't get rid of the dual boot window on startup? Thanks!

  10. #10
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,115
    Windows is a mystery to me sashag. I think when you used add/remove the first time that add/remove deleted or failed to delete some entry windows needed. Have you tried a system restore yet to a date previous to your install of wubi yet? That might be the route to take to fix this Windows problem. Worth a try. From reading info from below link, system32/hal/dll has ties with BOOT.INI file. So it is like a merry go round, catch-22 type problem. Here is the link I read.Windows XP Setup - Missing HAL.DLL

    I think you are ready also if none of the suggestions above work to download and burn and boot a Super Grub Disk Homepage . You can use it to fix Windows Bootloader so only Windows shows and boots up. Pick the last option on menu with all the sad smileys coming after the menu line. I think it says fix Windows boot only.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •