Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 28
I don't run Jaunty, so I wasn't aware of this particular issue. It would seem to me though that for a user initiated shutdown via the gui should play the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638

    I don't run Jaunty, so I wasn't aware of this particular issue. It would seem to me though that for a user initiated shutdown via the gui should play the user defined sound fle, and not just beep at you. The system bell is normal for a cli shutdown, and it's caused by the message dialog pop-up saying the system is going down. I would not consider it normal behavior for the beep to occur at a user gui shutdown.

    I'm sorry I stuck my nose in where I obviously didn't know enough about the situation, but then again, I did learn something. And BTW: no, that's not too much to ask from a single user or family system. The technical feat becomes a little more difficult when it's about managing many unrelated users, say at a library or a school, thus the current system which is *almost* as good... sans your Jaunty beep issue. I don't know if that's a bonafide bug or just a small oversight that occured while trying to make a deadline. I'm not a `buntu dev, so I can't speak to that.

  2. #12
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    Quote Originally Posted by D-cat View Post
    I don't run Jaunty, so I wasn't aware of this particular issue. It would seem to me though that for a user initiated shutdown via the gui should play the user defined sound fle, and not just beep at you. The system bell is normal for a cli shutdown, and it's caused by the message dialog pop-up saying the system is going down. I would not consider it normal behavior for the beep to occur at a user gui shutdown.

    I'm sorry I stuck my nose in where I obviously didn't know enough about the situation, but then again, I did learn something. And BTW: no, that's not too much to ask from a single user or family system. The technical feat becomes a little more difficult when it's about managing many unrelated users, say at a library or a school, thus the current system which is *almost* as good... sans your Jaunty beep issue. I don't know if that's a bonafide bug or just a small oversight that occured while trying to make a deadline. I'm not a `buntu dev, so I can't speak to that.
    Hey, thanks for trying. My bad if I forgot to mention Jaunty in the original post.

  3. #13
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    Since the system bell is playing instead of your chosen wav are you sure that the system isn't just having trouble playing your wav due to lack of support or a corrupted file?
    Linux User #453176

  4. #14
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    Quote Originally Posted by Kieren View Post
    Since the system bell is playing instead of your chosen wav are you sure that the system isn't just having trouble playing your wav due to lack of support or a corrupted file?
    Absolutely. Positively! To begin with, it doesn't play ANY sound clips at logout, restart, or shutdown, and at the last two there is the beep (it was totally silent when I did a logout, go figure). This was all demonstrated first with the default Ubuntu wavs within usr/share/sounds folder, not just mine. Anyway, I've already learned that the system won't play all file types (at least some mp3's) for this purpose, and any clip I try to use is proofed by the System->Preferences->Sound dialog (if it's no good for this use, you don't hear it play when you select it).

    The trouble is specifically with the session-terminating functions - there's no problem making my clips or the defaults play for startup - oh, but then there's other clips which were default-set for warnings, alerts, and errors, which I never heard since I upgraded to Jaunty. Not really sure what the appropriate triggers are for these, but there's the same tower beep if I try to move the cursor off my Text Editor window.

  5. #15
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    What, is there no more to say on this *beep*ing bug?

    I would presume that it's a fluke with my machine, but Thornspear described what sounds like the same problem.

    Oh, and I realize there are more important issues to deal with, maybe some at the security level. The problem is that expanding Linux use will not happen, owing to the impression which security makes on the potential converts, who are used to calling a techie whenever there's a virus attack. Their first impressions will be any apparent sloppiness with the interface programming, or difficulty of use! Bill Gates never concerned himself with anything other than user-friendliness, eye candy, and functionality, and it made him extremely rich. Therefore, the linux community needs to take more seriously what it's wealthy competitors are doing better, or it will lose momentum.

  6. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I never considered this to be a bug. The beep should be coming from the internal system speaker, not the sound card.

    This is what is does, it beeps when it is shut down abruptly. Big deal!

    To think that people won't want to use Linux because, when it is improperly shut down it beeps instead of playing a Star Wars audio clip is absurd. Yes, I changed this once on my windows box. It was neat, and I patted myself on the back for figuring how to change the default windows startup and shutdown audio. But, I quickly got over it.

    I suggest you do the same. It really isn't that big of a deal.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #17
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,127
    Right dudes...this system beep was configurable until Jaunty but now I can't seem to turn it off either.

    I haven't done a lot of research into it because my tower doesn't do it, just my laptop. However, that said it is an ear-piercing beep from the motherboard speaker and quite frustrating, especially in public. There are two things that stick out to me here
    • This used to be configurable through Preferences > Sounds
    • Everything in Linux should be configurable
    I know this can be turned off but the option that used to do it has no effect now. I'll have a look into it and see what I can find. It annoys the piss out of me as it is very loud on my laptop.

    EDIT - by the way Paul, this happens every shutdown. It does get kind of annoying, particularly since it's largely my non-techie wife that uses it.

  8. #18
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,127
    Think this is what we're looking at guys...

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/331589

  9. #19
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Quote Originally Posted by bigtomrodney View Post
    ...by the way Paul, this happens every shutdown. It does get kind of annoying, particularly since it's largely my non-techie wife that uses it.
    Sorry, that wasn't what was reported in the original post. I have three Ubuntu installs, and it doesn't do in on any of them, so excuse my misunderstanding of the problem.

    I do have a Debian based machine that does not shut down properly unless I run the shutdown command, then I get that beep. I don't find it excessively annoying though.

    Now that I checked it, my Ubuntu's don't make ANY sound when shutting down, when the settings say it should. Only the startup audio.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #20
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,127
    I think I may have misunderstood moreso, this problem has been on my to-do list for a while so I think I was too quick with my assumptions

    Just out of curiosity are any of your machines using intel chipsets? The bug on Launchpad seemed to point that way which would match my situation. My desktop PC has an nVidia chipset and doesn't have the problem, just my all-Intel laptop.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •