Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
I have complained before about the shutdown delay, which I know some people like, but it is never a cool feature when you need to reboot while troubleshooting. While it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40

    Question Shutdown beep


    I have complained before about the shutdown delay, which I know some people like, but it is never a cool feature when you need to reboot while troubleshooting. While it can be bypassed, there is a nasty system beep in place of your shutdown sound clip when you do that. Whether you interrupt the 60-second delay cycle, or tweak your settings to bypass it altogether, you still get that annoying system beep directly through your computer tower speaker, which after so many years of having customizable startup AND shutdown sounds of your choice (in stereo or surround-sound), this can be more than a little annoying. Much as I know it's hard for dedicated Ubuntu fanboys to understand, this geek would get tremendous satisfaction out of hearing that Star Wars laser blaster sound which he went to the trouble of setting up for his system shutdown (take that, cyberworld!). If there is a way to fix this now, I'd appreciate hearing from anyone who knows how, but otherwise I hope this is being considered in the next upgrade version.

    Thanks.

  2. #2
    Linux Newbie thornspear's Avatar
    Join Date
    Aug 2009
    Location
    Alberta, Canada
    Posts
    158
    strange, my system seems to have defaulted to the beep setting... Unless I have changed it unknowingly somewhere in my travels. How do you go about changing from the beep to shutdown delay?

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    Quote Originally Posted by thornspear View Post
    strange, my system seems to have defaulted to the beep setting... Unless I have changed it unknowingly somewhere in my travels. How do you go about changing from the beep to shutdown delay?
    What you just observed is just the problem which I want to fix.

    I had gone through my System->Preferences->Sound dialogue to change my default startup and shutdown sounds, but the shutdown wav doesn't play when the beep (from your tower box) takes over. As I said already, you get that beep (instead of your normal, or custum shutdown wav) when you interrupt the default 60-second shutdown (restart) dialogue, and it still happens when you right-click your dialogue icon, choose Preferences, and uncheck "Show confirm dialogues..."

  4. #4
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    It has nothing to do with personal settings. I assume you're bypassing the shutdown sequence by typing shutdown, poweroff, or reboot on the command line. This is "root" shutting down the system, not your user, so user setting don't apply. The CLI doesn't give a rats hind end who's logged in, it just kills everything; your logout/shutdown sound never has a chance to play. The beep you hear is actually just the system bell activated to call your attention when a wall message appears (like, system is going down NOW).

    I dont know how to kill the beep, but if you want to add a sound, you can do this by mucking with the scripts. In ubuntu, I think the script to edit is simply /etc/init.d/halt (some distros have a /etc/init.d/halt.local which is preferred). Add aplay /path/to/sound.wav somewhere early in the script and outside any functions, like say the line before ". /lib/lsb/init-functions".

  5. #5
    Linux Newbie
    Join Date
    Nov 2007
    Posts
    230
    is this the single loud system beep at shutdown ? I never had that for 2 years of using ubuntu, but since I installed mint 7, I get it now, but only on my dell desktop computer, my gateway laptop, doesn't do the beep, so I have been reading, about it, seems it goes all the way back to 2007. some people said it's a ram, or motherboard issue, and some say disable the speaker and ignore it... I sure can't figure it out.

  6. #6
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    Quote Originally Posted by thornspear View Post
    strange, my system seems to have defaulted to the beep setting... Unless I have changed it unknowingly somewhere in my travels. How do you go about changing from the beep to shutdown delay?
    My bad - I actually waited through the full minute (now matter how many people feel positively about this delay, that much time is a bit excessive), and found out that you get the pc/tower box beeping in place of whatever was set to play even when you wait. So, there are three choices through the Jaunty gui:

    1. Wait for the 60-second delay to complete

    2. Press the optional Restart or Shutdown button in the delay dialog box (or cancel),

    3. right-click the shutdown applet, select Preferences, uncheck "Show confirm dialogs for shutdown..."

    and they all terminate with that beep!

    Ubunutu engineers, there are more important things which I have to concern myself with than system sounds, and while there are worse sounds than my PC beep (such as the startup wavs for Windows and Ubuntu), you've got to admit it's crude for a modern system - least of all because it's almost never been heard in any context than "error".

  7. #7
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    Quote Originally Posted by D-cat View Post
    It has nothing to do with personal settings. I assume you're bypassing the shutdown sequence by typing shutdown, poweroff, or reboot on the command line.
    No, I fixed the the applet->preferences settings to stop that delay dialog from appearing, then I did the normal gui shutdown.

    Quote Originally Posted by D-cat View Post
    This is "root" shutting down the system, not your user, so user setting don't apply.
    So, how and why did that change? You know that most user systems which were produced since DOS days permitted the user his preferences for startup/system messages/shutdown sounds, so if it's the root cutting in, then why (must be something wrong)? Why, again, would the root give us that beep?

    Quote Originally Posted by D-cat;722781
    The CLI doesn't give a rats hind end who's logged in, it just kills everything; your logout/shutdown sound never has a chance to play. The beep you hear is actually just the system bell activated to call your attention when a wall message appears (like, system is going down NOW).

    I dont know how to kill the beep, but if you want to add a sound, you can do this by mucking with the scripts. In ubuntu, I think the script to edit is simply [I
    /etc/init.d/halt[/I] (some distros have a /etc/init.d/halt.local which is preferred). Add aplay /path/to/sound.wav somewhere early in the script and outside any functions, like say the line before ". /lib/lsb/init-functions".
    So, this script is on a higher-level than those behind the dialog of System->Preferences->Sounds? Would I know this by their being present in the root directory (and then are my user preferences all stored somewhere among the hidden folders of my home directory?

    Thanks.

  8. #8
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Reading this, I'm not sure we're talking about the same thing. I'm referring to the beep that occurs when you shut down via the command line. If you're talking about something happening when you use the GUI "logout" button, then my analysis is wrong.

    As far as the scripts are concerned, yes, this script is on a "higher level" than the user. User settings are kept in hidden folders in your home directory. Anything from /etc is a system setting that the user has little or no control over. This is by design for a posix system; it's so in a multi-user environment one user can't mess with everyone else's session. Changes in /etc affect all users, changes in your home directory (personal settings) only affect you.

    When shutting down, services will be terminated rather efficiently, so adding a sound has to occur before the sound module is unloaded. That's why I suggested placing it before the call to init-functions.

    Root services typically get your attention with the system bell (speaker beep) because it's a universal call that doesn't require any special or additional files present or setup tweaking. It's just a way of getting things running quickly, that's all. I've never experienced a minute long beep though, it has always been quick, therefore I feel I'm kind of shooting in the dark here now.

    Calling a root function for shutdown is necessary again because Linux is designed as a multi-user system... you wouldn't want any of however many simultaneous users being able to shut down the whole system for everybody at any time, would you? The actual reboot and poweroff buttons should only be available in the gui to the last user left logged in at a local terminal. Otherwise it can only be done from the CLI as a superuser (root or sudo).

    The setup is fundamentally different from DOS, which was only designed to give a single user basic and full control of a single machine. Thus, DOS based customizations and up through windows were easy since multi-user security wasn't an issue for its original intended use. Linux attempts to still make the personal settings as easy as Windows while working in a secure environment. Small snags like this occasionally pop up, but it's a better approach from a security standpoint than has been Windows' classic take on til recent.

  9. #9
    Linux Newbie thornspear's Avatar
    Join Date
    Aug 2009
    Location
    Alberta, Canada
    Posts
    158
    It is my tower that is beeping. It does a quick triple beep actually. Matter of fact, I just let the 60 second delay countdown on my desktop and it did a quick triple beep. I've never shut my system down using the terminal.

    I just tried the right click on power applet, followed by preferences and unchecking "show confirm dialogs" box. System is still beeping 2 or 3 times.

    I don't ever remember my laptop beeping like this...

  10. #10
    Just Joined!
    Join Date
    Mar 2009
    Posts
    40
    Quote Originally Posted by D-cat View Post
    Reading this, I'm not sure we're talking about the same thing. I'm referring to the beep that occurs when you shut down via the command line. If you're talking about something happening when you use the GUI "logout" button, then my analysis is wrong.

    As far as the scripts are concerned, yes, this script is on a "higher level" than the user. User settings are kept in hidden folders in your home directory. Anything from /etc is a system setting that the user has little or no control over. This is by design for a posix system; it's so in a multi-user environment one user can't mess with everyone else's session. Changes in /etc affect all users, changes in your home directory (personal settings) only affect you.

    When shutting down, services will be terminated rather efficiently, so adding a sound has to occur before the sound module is unloaded. That's why I suggested placing it before the call to init-functions.

    Root services typically get your attention with the system bell (speaker beep) because it's a universal call that doesn't require any special or additional files present or setup tweaking. It's just a way of getting things running quickly, that's all. I've never experienced a minute long beep though, it has always been quick, therefore I feel I'm kind of shooting in the dark here now.
    Thornspear and I are talking about a Jaunty issue with the GUI control of the normal restart/shutdown (normal for GUI users). The beep does not last for a whole minute (guess it could be worse), but we do get a beep before the actual restart/shutdown, whether we've waited for the delay to complete, pressed the option within the delay dialog to continue (restart/shutdown), or set the GUI preferences to proceed without the delay dialog. The beep is played, instead of the, err.. "logout" sound clip, as it's referred to in the System->Preferences->Sounds dialog.

    The "login" and "logout lines are set to call the soundclips which you would hear when you start or end a session (start/shutdown), and the default sound clips are the African drums which Ubuntu prides itself on, and we can test our substitute files within that dialog.

    What's missing now is not the option to set up a brief clip to be played when you logout, but that the beep is played instead. You seem to have indicated that this is normal root behavior, and something of a technical feat to override, but this has not been insurmountable for prior versions of Ubuntu, nor for most recent OSs.

    Quote Originally Posted by D-cat View Post
    Calling a root function for shutdown is necessary again because Linux is designed as a multi-user system... you wouldn't want any of however many simultaneous users being able to shut down the whole system for everybody at any time, would you? The actual reboot and poweroff buttons should only be available in the gui to the last user left logged in at a local terminal. Otherwise it can only be done from the CLI as a superuser (root or sudo).
    Windows XP and Vista are also multi-user systems, they just aren't quite as secure. They produce a warning dialog when there is more than one active session, but they somehow know enough not to when there isn't more than one session open. Is that too much elegance to demand of Ubuntu? This, and the rough beep in place of playing the sound clips which are supported for play at that moment by another part of the OS, are sort of embarrassing rough spots which need dealing with. Nobody attacks the idea behind these changes with Jaunty, but we want everything else to work, too.


    Quote Originally Posted by D-cat View Post
    The setup is fundamentally different from DOS, which was only designed to give a single user basic and full control of a single machine. Thus, DOS based customizations and up through windows were easy since multi-user security wasn't an issue for its original intended use. Linux attempts to still make the personal settings as easy as Windows while working in a secure environment. Small snags like this occasionally pop up, but it's a better approach from a security standpoint than has been Windows' classic take on til recent.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •