Find the answer to your Linux question:
Results 1 to 7 of 7
I recently installed Ubuntu 9.10 on to my Dell XPS m1330 that originally came with Vista. This is my first foray into Linux, and installation and configuration went great. HOWEVER, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    3

    Dell XPS m1330 Wireless problems


    I recently installed Ubuntu 9.10 on to my Dell XPS m1330 that originally came with Vista. This is my first foray into Linux, and installation and configuration went great. HOWEVER, I have been unable to connect to any Wifi networks with this machine. They simply won't show up on the network manager window. I ran the System Testing program and it said my wireless controller was as follows:

    Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
    Broadcom Corporation BCM4312 802.11b/g (rev 01)

    Any help would be greatly appreciated.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Are you able to get a wired connection briefly?

    If so, you can do
    Code:
    sudo apt-get update && sudo apt-get install bcmwl-kernel-source
    Or for a GUI method, use Synaptic as described here.

  3. #3
    Just Joined!
    Join Date
    Nov 2009
    Posts
    3
    No, I'm unable to get any connection, even briefly.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    No friends with an ethernet connection?

    You'll need to download the packages from a different computer to a flash drive or the like, transfer them over and install. The problem with this is sometimes getting all the dependencies is a pain.

    I believe these are all you need, however.
    http://mirrors.kernel.org/ubuntu/poo...buntu1_all.deb
    http://mirrors.kernel.org/ubuntu/poo...untu4_i386.deb
    http://mirrors.kernel.org/ubuntu/poo...untu1_i386.deb
    http://mirrors.kernel.org/ubuntu/poo...5.9-5_i386.deb

    These are links to the 32 bit versions. If you're running 64 bit, you'll need different files. If you just chose the default Ubuntu download, it's 32 bit.

    Once you transfer them to your Ubuntu box, you should be able to double click to open gdebi, an installer program for .deb files. I think you'll need to install dkms, fakeroot, and patch before bcmwl-kernel-source.

    Post back if you get errors and we'll try and figure it out.

  6. #5
    Just Joined!
    Join Date
    Nov 2009
    Posts
    3
    Thanks for all your help! Works like a charm.

  7. #6
    Just Joined!
    Join Date
    Dec 2009
    Posts
    1
    I followed the nstructions on my Dell insprion 1520.. Boy I tell you it WORKS!!!!

  8. #7
    Just Joined!
    Join Date
    Nov 2010
    Posts
    1
    I'm trying to manage this same thing... I used these files, but it's telling me something about the dkms file that it doesn't like.

    I'm working w/ an HP mini netbook - not sure that makes a difference. The fakeroot and patch files worked fine.

    Is there an updated dkms file that I need?

    Thanx! =)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •