Find the answer to your Linux question:
Results 1 to 6 of 6
Everytime I start my computer it says "Ubuntu is running in low graphics mode". None of the options it gives me works except "Exit to console login" I choose this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2008
    Location
    England, Manchester.
    Posts
    114

    [SOLVED] Ubuntu is running in low graphics mode


    Everytime I start my computer it says "Ubuntu is running in low graphics mode".
    None of the options it gives me works except "Exit to console login" I choose this and type "sudo dpkg-reconfigure xserver-xorg" then type "startx" but the next time I start my computer it does the same thing again. Its kind of annoying bbecause I have to set the resolution and set up emerald and compiz again.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which Graphics Card do you have?
    Post the contents of /etc/X11/xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Newbie
    Join Date
    Mar 2008
    Location
    England, Manchester.
    Posts
    114
    I have an Nvidia 9800 GT.

    Ubuntu downloaded the drivers for me ages ago right after install...


    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	DefaultDepth	24
    EndSection
    
    Section "Module"
    	Load	"glx"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver	"nvidia"
    	Option	"NoLogo"	"True"
    EndSection
    Thanks for your help!

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Backup xorg.conf file and create an empty xorg.conf file.
    Code:
    cd /etc/X11
    sudo mv xorg.conf xorg.conf.1
    sudo touch xorg.conf
    Execute this to reconfigure display.
    Code:
    sudo nvidia-settings
    Save configuration and reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Linux Newbie
    Join Date
    Mar 2008
    Location
    England, Manchester.
    Posts
    114
    Thanks for your reply!

    I backed it up and made a new blank one and tried "sudo nvidia-settings" and it said,

    Code:
    VALIDATION ERROR:  Data incomplete in file /etc/X11/xorg.conf.
    At least one Device section is required.
    
    Segmentation fault
    It also told me that I should run nvidia-xconfig and restart.

    I done this then tried "sudo nvidia-settings" again and configured it, clicked apply then clicked save to x configuration file and restarted, but the problem is still there?

  7. #6
    Linux Newbie
    Join Date
    Mar 2008
    Location
    England, Manchester.
    Posts
    114
    I fixed it!

    I done a "sudo apt-get remove gdm" and then a "sudo apt-get install gdm" and now its logging in again!

    Kinda weird that fixed... bit yeah...


    Thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •