Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi! I use Ubuntu 9.10 after upgrade from 9.04. But my NVIDIA not detect my TV. Here i can not choose other option than "Separate X screen......": (see atach)! I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    8

    Ubuntu 9.10 - No detect the TV


    Hi! I use Ubuntu 9.10 after upgrade from 9.04. But my NVIDIA not detect my TV. Here i can not choose other option than "Separate X screen......":
    (see atach)!
    I try to uninstall NVIDIA driver and install again, but no efekt. Last i install driver 190.53 manual. Try to change my xorg.conf with other options, but without result! Now my xorg.conf is reset and loks like:

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "ACI VW222"
    HorizSync 31.0 - 81.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 9500 GT"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "metamodes" "CRT: 1680x1050_60_0 +0+0, TV: nvidia-auto-select +1680+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection
    Attached Images Attached Images

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    use nvidia-settings tool to configure your TV, it is the easiest way

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    8
    I use Nvidia-settings (sudo nvidia-settings)- see atach in the first messages!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4

    This is a bug

    This seems to be the exact issue I've had for months now using a geforce 9500 gt.

    The only fix I've found as of yet is to install a patched version of the driver 185.18.14. The forums here wont let me post a link so you'll have to google for "Patch for Nvidia 185.18.14 to build on 2.6.31 kernel"
    Follow the instructions there on how to patch it and then add this to your Device section in xorg.conf...

    Option "ConnectedMonitor" "CRT, TV"
    Option "TVStandard" "NTSC-M"
    Option "TVOutFormat" "SVIDEO"


    Making sure to change TVStandard to whatever your region uses.

    You can find updates on the issue by going to the NVNews forum and searching for "TV Not working with new nvidia drivers"

  6. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    8
    Thank you! I will try to find this patch for 185.18.14. But now i'm with NVidia drivers v.190.53 - I must install 185.18.14 before try the patch, may be ?!

  7. #6
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    most likely you will uninstall the current drivers, then download the other driver set and apply patch, then install them

  8. #7
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4
    You'll need 185.18.14 or it wont work. Those are the newest drivers that don't have this bug.

  9. #8
    Just Joined!
    Join Date
    Jan 2010
    Posts
    8
    coopstah13, i can't patch the NVIDIA-Linux-x86_64-185.18.14-pkg2.run. After:
    sh ./NVIDIA-Linux-x86_64-185.18.14-pkg2.run --apply-patch nvidia-185.18.14.patch
    i sее:
    Couldn't locate the 'patch' utility.

  10. #9
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4
    First, make sure that your typing the actual name of the driver that you downloaded.

    The instructions to apply the patch are for a driver for a 64 bit system and the driver is also "pkg2", which your driver is most likely "pkg1".

    for example: the instructions say "./NVIDIA-Linux-x86_64-185.18.14-pkg2.run"
    but the driver I, and most likely you, downloaded from the nvidia site would be...

    ./NVIDIA-Linux-x86-185.18.14-pkg1.run

    Also did you make sure the patch is in the same directory as the driver?

  11. #10
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4
    And make sure that the program "patch" is installed.

    sudo apt-get install patch

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •