Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I have 2 computer: 1 computer install ubuntu v9.10, in this computer already installed openssh-server and openssh-client, and 1 computer install windows. In computer with windows , i used putty ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6

    How to use Putty connect to Ubuntu?


    I have 2 computer: 1 computer install ubuntu v9.10, in this computer already installed openssh-server and openssh-client, and 1 computer install windows. In computer with windows , i used putty connect to computer with ubuntu, but i can't connect. I don't understand what's error.
    In the Putty , i configured:
    IP : IP address of computer Ubuntu.
    Port 22
    Connection Type SSH

    This is error: "Network Error: Software caused connection abort"

    In computer with windows, i can ping computer with ubuntu and in computer with ubuntu i can ping computer with windows.

    I already checked computer with ubuntu :
    - /etc/ssh/sshd_config: in this file port 22, PermitRootLogin yes...

    And in this machine installed with openssh-server, and openssh-client. But in this time, this error is maintaining, i don't find idea to fix this error.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Check the file /etc/hosts.allow

    It is likely you need to specifically allow your windows client to connect to your server. The simplest and least secure form would be to put
    Code:
    sshd: ALL
    But you could put that in there as a test. If it works, you know that was the problem and you can change it to something more secure.

    hosts.allow - Linux Command - Unix Command
    Keeping SSH access secure

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Thanks for your reply, but now it doesn't work !

    In my auth.log this is error:

    Code:
    error: ssh_selinux_getctxbyname: Failed to get default SELinux security context for kobold
    error: ssh_selinux_setup_exec_context: Failed to set SELinux execution context for kobold
    i don't understand this error, and how can fix it? Can you give some idea?

  4. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Who have got any idea? Can give me ,plz! This problem i can't fix it

  5. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    PermitRootLogin yes
    Logging in as root is a terrible idea generally - have you tested with regular users?

  6. #6
    Just Joined!
    Join Date
    Feb 2010
    Posts
    1
    Are your computers connected via a router?

    If yes, on your Ubuntu computer open a terminal and enter ifconfig
    Take a note of the ipaddress. Let's say it is 192.168.1.5

    On your windows computer, open a command prompt and type ipconfig.
    Take a note of the ipaddress. Let's say it is 192.168.1.7

    Ping 192.168.1.5
    Do you get a response?

    open putty on your windows computer
    ssh your_ubuntu_username@192.168.1.5
    enter your ubuntu password

    Are you connected yet?

  7. #7
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    so if you disable selinux does it fix your problem?

    Code:
    setenforce permissive
    linux user # 503963

  8. #8
    Just Joined!
    Join Date
    Jul 2009
    Posts
    20
    yes disable SElinux or set it on permissive mode as mentioned above ,would permit ssh access to your machine

    --Sims

  9. #9
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Quote Originally Posted by bigtomrodney View Post
    Logging in as root is a terrible idea generally - have you tested with regular users?
    I have known that logging in as root is terrible, but i only connect with user root, user kobold in group admin , i don't understand what's happen?
    Quote Originally Posted by kesey View Post
    Are your computers connected via a router?

    If yes, on your Ubuntu computer open a terminal and enter ifconfig
    Take a note of the ipaddress. Let's say it is 192.168.1.5

    On your windows computer, open a command prompt and type ipconfig.
    Take a note of the ipaddress. Let's say it is 192.168.1.7

    Ping 192.168.1.5
    Do you get a response?

    open putty on your windows computer
    ssh your_ubuntu_username@192.168.1.5
    enter your ubuntu password

    Are you connected yet?
    With 2 computers , i can ping normally ,but i haven't used putty to connect computer ubuntu

    Quote Originally Posted by scathefire View Post
    so if you disable selinux does it fix your problem?

    Code:
    setenforce permissive
    Quote Originally Posted by simha View Post
    yes disable SElinux or set it on permissive mode as mentioned above ,would permit ssh access to your machine

    --Sims
    i will try to disable selinux, thanks !

  10. #10
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    Quote Originally Posted by scathefire View Post
    so if you disable selinux does it fix your problem?

    Code:
    setenforce permissive
    I used
    Code:
    setenforce permissive
    but error has maintained, how to disable selinux????

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •