Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Ubuntu shuts itself down and displays message that it is running low on graphics, giving me options to run in low graphics mode or to troubleshoot. I have been given ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    76

    Unhappy My Ubuntu 10.04 shuts itself down low on graphics


    Ubuntu shuts itself down and displays message that it is running low on graphics, giving me options to run in low graphics mode or to troubleshoot. I have been given the following advice but have no idea what to do:

    You are using the open driver i915 as you are using an intel based video
    chip.

    Sounds like you need an xorg.conf file to define the display a little better as udev is not detecting. Here is a sample file you can start with: (Refers to a URL that led me to this forum)

    You can ignore any sections and entrys regarding keyboards as udev is
    pretty awesome at picking those up

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Post the output of this
    Code:
    lspci | grep -i vga
    Post the contents of /etc/X11/xorg.conf file too.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    76
    Quote Originally Posted by devils casper View Post
    Hi and Welcome !

    Post the output of this
    Code:
    lspci | grep -i vga
    Post the contents of /etc/X11/xorg.conf file too.
    lspci | grep -i vga
    00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)

    Cannot find /etc/X11/xorg.conf

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Alt+F2 and type this
    Code:
    gksu gedit /etc/X11/xorg.conf
    It will open xorg.conf file in Gedit with root privileges.

    Delete all contents of xorg.conf file, if there are any. Copy following contents and paste in xorg.conf file :
    Code:
    Section "Device"
           Identifier "Configured Video Device"
           Driver    "i810"  
    EndSection
    
    Section "Monitor"
             Identifier "Configured Monitor"
             HorizSync 31.5 - 70.0
             VertRefresh 50 - 160
     EndSection
    
    Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "Configured Video Device"
            DefaultDepth 24
            Subsection "Display"
                 Depth 24
                 Modes "1280x1024" "1024x768" 
            EndSubsection
    EndSection
    Save file and reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    76
    Many thanks. The restart/shut down works now, but I receive the following message on restart:

    Ubuntu is running low in graphics mode. The following error was encountered:
    You may need to update your configuration to solve this.
    (EE) Failed to load module "i810" (module does not exist, 0)
    (EE) No drivers available

    Then I select the option to run Ubuntu in low graphics mode for one session and everything seems to run fine.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Replace "i810" with "intel" in /etc/X11/xorg.conf file.
    Code:
    Section "Device"
           Identifier "Configured Video Device"
           Driver    "intel"  
    EndSection
    In case it doesn't work, replace it "intel" with "vesa".
    vesa is a generic driver and works fine with most of Graphics Cards.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Aug 2010
    Posts
    76
    Thanks, I have implemented all of these suggestions but the problem persists.

  8. #8
    Linux Engineer Segfault's Avatar
    Join Date
    Jun 2008
    Location
    Acadiana
    Posts
    877
    How much memory you have allocated for video in BIOS setup.

  9. #9
    Just Joined!
    Join Date
    Aug 2010
    Posts
    76

    My Ubuntu 10.04 shuts itself down low on graphics

    Have not allocated anything, unable to locate video settings in bios setup, where do I find these?

    Error message now being received is:

    (EE) VESA: kernel modesetting driver in use, refusing to load
    (EE) no drives detected
    Last edited by Langjan; 08-18-2010 at 10:24 PM. Reason: Additional information

  10. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Remove Driver line from xorg.conf file.
    Code:
    Section "Device"
           Identifier "Configured Video Device"
    EndSection
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •