Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I have set up Ubuntu 10.04 with a data partition mounted as /share that I would like to make available to all users. I have only managed to do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    2

    How do I create a shared folder?


    Hi,

    I have set up Ubuntu 10.04 with a data partition mounted as /share that I would like to make available to all users.

    I have only managed to do this so far by using chmod and chown, can I flag the folder so that all users can read and write from it automatically? I'm looking for something a bit like "Ignore Ownership" on a Mac.

    Any help greatly appreciated

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    chmod is how you do this. Try 'chmod o+rw <directory>', or even 'chmod o+rwx <directory>'.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Sep 2010
    Posts
    2
    Thanks for that.

    This is what I've done already, I've run:

    chmod -R a+rwx /share

    and

    chwon -R :users /share

    after creating a group called users and adding everyone to it.

    This means all users can access the folder and the files within but when any user creates a new file or folder within I need to run the above commands again to make it available to all.

    What I was really after is a way to apply full rights to anything put into that folder at the point of creation.

    Is there a way to do this?

    Thanks again or your help

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    1
    Do you fix it ??

    I am trying to do the same, I am using ACL to give full rights to a group, users can create/delete files & folders, but it some one copy a folder (drag&drop from Desktop to sharedfolder) just the owner can upadte/delete files or folder.

    /etc/fstab with acl on <options> column

    cd /home
    sudo mkdir SharedDir
    sudo groupadd sharefl
    sudo usermod -G sharefl -a user1
    sudo usermod -G sharefl -a user2

    sudo chmod -R g+rwx SharedDir
    sudo chown -R root:sharefldr SharedDir

    setfacl -R -m g:sharefldr:rwx SharedDir
    setfacl -R -d -m g:sharefldr:rwx SharedDir

    Regards

  5. #5
    Just Joined!
    Join Date
    Oct 2012
    Posts
    1
    I ran into the same problem with Suse Linux 12.1. In my case it was SAMBA. I applied all the permission I could in Linux, but the problem was SAMBA, so using Webmin, I gave my shared folder a samba permission 777. That fixed the problem.

  6. #6
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,377
    hi
    Your contribution is appreciated, but this is an old thread. Closing
    You must always face the curtain with a bow.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •