Find the answer to your Linux question:
Results 1 to 7 of 7
Hello! I had a problem with viewing webcams on Skype, and after searching I found out that running Skype through the terminal with this command "export XLIB_SKIP_ARGB_VISUALS=1 && skype" makes ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Posts
    4

    Creating custom command/menu launcher


    Hello!

    I had a problem with viewing webcams on Skype, and after searching I found out that running Skype through the terminal with this command "export XLIB_SKIP_ARGB_VISUALS=1 && skype" makes the webcams work perfectly.

    What I wanted to do was to integrate this command into the main menu so that I won't have to type it into the terminal (and thus keep the terminal open all the session) every time I want to use Skype.

    So I edited the command of the Skype button in the Applications menu and put that line instead of "skype", but it gives me "Failed to execute child process "export" (No such file or directory)".

    I tried editing .bashrc and added the following line:
    alias skp='export XLIB_SKIP_ARGB_VISUALS=1 && skype'
    Now the command 'skp' works through the terminal, but it gives me the same error message when I put it into the command line of the applications menu.

    How do I work this out ?

    Thank you.

  2. #2
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    create a script file with the commands you need and make it executable. then place it to a directory listed in
    Code:
    echo $PATH
    and it should work. The most suitable directory will be /usr/local/bin/

  3. #3
    Just Joined!
    Join Date
    May 2010
    Posts
    4
    Thanks for the reply Kloschüssel

    But how exactly do I create that script file and make it executable ?

  4. #4
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,284
    Open a terminal

    Create a text file with

    sudo nano /usr/bin/local/myskype

    put the following in it

    Code:
    #! /bin/bash
    export XLIB_SKIP_ARGB_VISUALS=1 && skype
    and then make it executable by

    sudo chmod +x /usr/local/bin/myskype

    Note you don't have to call it myskype
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  5. #5
    Just Joined!
    Join Date
    May 2010
    Posts
    4
    Thank you elija! That works

  6. #6
    Just Joined!
    Join Date
    May 2010
    Posts
    4
    I've updated to Maverick (ubuntu 10.10) and now I'm trying to create this command again, but it doesn't work. When I try to save the file I created, it gives me:
    [ Error writing /usr/bin/local/myskype: No such file or directory ]

    Help please! Thank you...

  7. #7
    Linux Engineer Kloschüssel's Avatar
    Join Date
    Oct 2005
    Location
    Italy
    Posts
    773
    [ Error writing /usr/bin/local/myskype: No such file or directory ]
    /usr/local/bin <> /usr/bin/local

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •