Find the answer to your Linux question:
Results 1 to 6 of 6
HI I upgraded Netbook edition from Lucid to Maverick, and it's gone horribly wrong. It may be because I had set up the a Gnome session in Lucid so that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Location
    Inthe bush somewhere in South Afica
    Posts
    11

    Distro upgrade gone wrong HELP


    HI

    I upgraded Netbook edition from Lucid to Maverick, and it's gone horribly wrong. It may be because I had set up the a Gnome session in Lucid so that I could add and remove applets to panel in while still having the netbook session layout.

    After distro upgrade I ended up with a hybrid system with both the unity launcher AND the Lucid-style UNE launcher. Unity does not recognise any of my installed software, e.g open office or bibus in "Office". UNE launcher does. There is also no option of Gnome session at login, only Desktop and Netbook!

    When I run sudo apt-get upgrade, I get the following long list of errors below (ending with "Processing was halted because there were too many errors.
    E: Sub-process /usr/bin/dpkg returned an error code (1)". Any advice gratefully accepted!

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages have been kept back:
      cups odbcinst unixodbc
    0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    476 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Setting up gconf2 (2.31.91-0ubuntu3.1) ...
    Traceback (most recent call last):
      File "/usr/bin/update-gconf-defaults", line 162, in <module>
        read_entries(realname)
      File "/usr/bin/update-gconf-defaults", line 121, in read_entries
        for line in file(filename):
    IOError: [Errno 21] Is a directory: '/usr/share/gconf/mandatory/share'
    dpkg: error processing gconf2 (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of libgnomevfs2-common:
     libgnomevfs2-common depends on gconf2 (>= 2.28.1); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libgnomevfs2-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnomevfs2-0:
     libgnomevfs2-0 depends on libgnomevfs2-common (>= 1:2.24); however:
      Package libgnomevfs2-common is not configured yet.
     libgnomevfs2-0 depends on libgnomevfs2-common (<< 1:2.25); however:
      Package libgnomevfs2-common is not configured yet.
    dpkg: error processing libgnomevfs2-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnome2-common:
     libgnome2-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libgnome2-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnNo apport report written because the error message indicates its a followup error from a previous failure.
      No apport report written because the error message indicates its a followup error from a previous failure.
                                No apport report written because MaxReports is reached already
              No apport report written because MaxReports is reached already
                                                                            No apport report written because MaxReports is reached already
                                                          No apport report written because MaxReports is reached already
                                        No apport report written because MaxReports is reached already
                      No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                No apport report written because MaxReports is reached already
                              No apport report written because MaxReports is reached already
            No apport report written because MaxReports is reached already
                                                                          ome2-0:
     libgnome2-0 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
      Package libgnomevfs2-0 is not configured yet.
     libgnome2-0 depends on libgnome2-common (>= 2.32); however:
      Package libgnome2-common is not configured yet.
     libgnome2-0 depends on libgnome2-common (<< 2.33); however:
      Package libgnome2-common is not configured yet.
    dpkg: error processing libgnome2-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libbonoboui2-0:
     libbonoboui2-0 depends on libgnome2-0 (>= 2.17.3); however:
      Package libgnome2-0 is not configured yet.
    dpkg: error processing libbonoboui2-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgweather-common:
     libgweather-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libgweather-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problemsNo apport report written because MaxReports is reached already
           No apport report written because MaxReports is reached already
                                                                         No apport report written because MaxReports is reached already
                                                       No apport report written because MaxReports is reached already
                                     No apport report written because MaxReports is reached already
                   No apport report written because MaxReports is reached already
                                                                                 No apport report written because MaxReports is reached already
                                                               No apport report written because MaxReports is reached already
                                             No apport report written because MaxReports is reached already
                           No apport report written because MaxReports is reached already
         No apport report written because MaxReports is reached already
                                                                       No apport report written because MaxReports is reached already
                                                     No apport report written because MaxReports is reached already
                                    prevent configuration of libgweather1:
     libgweather1 depends on libgweather-common (>= 2.24.0); however:
      Package libgweather-common is not configured yet.
    dpkg: error processing libgweather1 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libpanel-applet2-0:
     libpanel-applet2-0 depends on libbonoboui2-0 (>= 2.15.1); however:
      Package libbonoboui2-0 is not configured yet.
     libpanel-applet2-0 depends on libgnome2-0 (>= 2.17.3); however:
      Package libgnome2-0 is not configured yet.
    dpkg: error processing libpanel-applet2-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-applets-data:
     gnome-applets-data depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing gnome-applets-data (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-panel-data:
     gnome-panelNo apport report written because MaxReports is reached already
                                                                              No apport report written because MaxReports is reached already
                                                            No apport report written because MaxReports is reached already
                                          No apport report written because MaxReports is reached already
                        -data depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing gnome-panel-data (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of capplets-data:
     capplets-data depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing capplets-data (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnomekbd-common:
     libgnomekbd-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libgnomekbd-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnomekbd4:
     libgnomekbd4 depends on libgnomekbd-common (>= 2.32.0-0ubuntu1); however:
      Package libgnomekbd-common is not configured yet.
    dpkg: error processing libgnomekbd4 (--configure):
     dependency problems - leaving unconfiguredNo apport report written because MaxReports is reached already
    
    dpkg: dependency problems prevent configuration of metacity-common:
     metacity-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing metacity-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libmetacity-private0:
     libmetacity-private0 depends on metacity-common (>= 1:2.30); however:
      Package metacity-common is not configured yet.
     libmetacity-private0 depends on metacity-common (<< 1:2.31); however:
      Package metacity-common is not configured yet.
    dpkg: error processing libmetacity-private0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-settings-daemon:
     gnome-settings-daemon depends on libgnomekbd4 (>= 2.31.5); however:
      Package libgnomekbd4 is not configured yet.
     gnome-settings-daemon depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
     gnome-settings-daemon dependsNo apport report written because MaxReports is reached already
                 on libgnome2-common; however:
      Package libgnome2-common is not configured yet.
    dpkg: error processing gnome-settings-daemon (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-control-center:
     gnome-control-center depends on libgnomekbd4 (>= 2.31.5); however:
      Package libgnomekbd4 is not configured yet.
     gnome-control-center depends on libmetacity-private0 (>= 1:2.26.0); however:
      Package libmetacity-private0 is not configured yet.
     gnome-control-center depends on capplets-data (>= 1:2.32.0-0ubuntu2); however:
      Package capplets-data is not configured yet.
     gnome-control-center depends on capplets-data (<< 1:2.33); however:
      Package capplets-data is not configured yet.
     gnome-control-center depends on gnome-settings-daemon (>= 2.30); however:
      Package gnome-settings-daemon is not configured yet.
    dpkg: error processing gnome-control-center (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems pNo apport report written because MaxReports is reached already
             revent configuration of libgnomeui-0:
     libgnomeui-0 depends on libbonoboui2-0 (>= 2.15.1); however:
      Package libbonoboui2-0 is not configured yet.
     libgnomeui-0 depends on libgnome2-0 (>= 2.17.3); however:
      Package libgnome2-0 is not configured yet.
     libgnomeui-0 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
      Package libgnomevfs2-0 is not configured yet.
    dpkg: error processing libgnomeui-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-gnome2:
     python-gnome2 depends on libbonoboui2-0 (>= 2.15.1); however:
      Package libbonoboui2-0 is not configured yet.
     python-gnome2 depends on libgnome2-0 (>= 2.17.3); however:
      Package libgnome2-0 is not configured yet.
     python-gnome2 depends on libgnomeui-0 (>= 2.22.0); however:
      Package libgnomeui-0 is not configured yet.
     python-gnome2 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
      Package libgnomevfs2-0 is not configured yet.
    dpkg: error processing python-gnome2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-about:
     gnome-about depends on python-gnome2; however:
      Package python-gnome2 is not configured yet.
    dpkg: error processing gnome-about (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-panel:
     gnome-panel depends on libbonoboui2-0 (>= 2.15.1); however:
      Package libbonoboui2-0 is not configured yet.
     gnome-panel depends on libgweather1 (>= 2.30.0); however:
      Package libgweather1 is not configured yet.
     gnome-panel depends on libpanel-applet2-0 (>= 2.26.0); however:
      Package libpanel-applet2-0 is not configured yet.
     gnome-panel depends on gnome-panel-data (>= 1:2.30); however:
      Package gnome-panel-data is not configured yet.
     gnome-panel depends on gnome-panel-data (<< 1:2.31); however:
      Package gnome-panel-data is not configured yet.
     gnome-panel depends on gnome-control-center (>= 1:2.8.2-3); however:
      PackagNo apport report written because MaxReports is reached already
                                                                          No apport report written because MaxReports is reached already
                                                        e gnome-control-center is not configured yet.
     gnome-panel depends on gnome-about (>= 2.10.0-1); however:
      Package gnome-about is not configured yet.
     gnome-panel depends on python-gnome2; however:
      Package python-gnome2 is not configured yet.
    dpkg: error processing gnome-panel (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of nautilus-data:
     nautilus-data depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing nautilus-data (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of nautilus:
     nautilus depends on nautilus-data (>= 1:2.32); however:
      Package nautilus-data is not configured yet.
     nautilus depends on nautilus-data (<< 1:2.33); however:
      Package nautilus-data is not configured yet.
    dpkg: error processing nautilus (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-media-common:
     gnome-media-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing gnome-media-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgnome-media0:
     libgnome-media0 depends on gnome-media-common (>= 2.31); however:
      Package gnome-media-common is not configured yet.
     libgnome-media0 depends on gnome-media-common (<< 2.32); however:
      Package gnome-media-common is not configured yet.
    dpkg: error processing libgnome-media0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-good:
     gstreamer0.10-plugins-good depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing gstreamer0.10-plugins-good (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of rhythmbox:
     rhythmbox depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
     rhythmbox depends on libgnome-media0; however:
      Package libgnome-media0 is not configured yet.
     rhythmbox depends on gstreamer0.10-plugins-good (>= 0.10.7); however:
      Package gstreamer0.10-plugins-good is not configured yet.
     rhythmbox depends on python-gnome2 (>= 2.18); however:
      Package python-gnome2 is not configured yet.
    dpkg: error processing rhythmbox (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gnome-applets:
     gnome-applets depends on libbonoboui2-0 (>= 2.15.1); however:
      Package libbonoboui2-0 is not configured yet.
     gnome-applets depends on libgweather1 (>= 2.30.0); however:
      Package libgweather1 is not configured yet.
     gnome-applets depends on libpanel-applet2-0 (>= 2.26.0); however:
      Package libpanel-applet2-0 is not configured yet.
     gnome-applets depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
     gnome-applets depends on gnome-applets-data (>= 2.30); however:
      Package gnome-applets-data is not configured yet.
     gnome-applets depends on gnome-applets-data (<< 2.31); however:
      Package gnome-applets-data is not configured yet.
     gnome-applets depends on gnome-panel (>= 2.13.4); however:
      Package gnome-panel is not configured yet.
    dpkg: error processing gnome-applets (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of yelp:
     yelp depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing yelp (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ubuntu-docs:
     ubuntu-docs depends on yelp; however:
      Package yelp is not configured yet.
    dpkg: error processing ubuntu-docs (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of aisleriot:
     aisleriot depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing aisleriot (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgksu2-0:
     libgksu2-0 depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing libgksu2-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gksu:
     gksu depends on libgksu2-0 (>= 2.0.8); however:
      Package libgksu2-0 is not configured yet.
    dpkg: error processing gksu (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of software-properties-gtk:
     software-properties-gtk depends on gksu; however:
      Package gksu is not configured yet.
    dpkg: error processing software-properties-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apturl:
     apturl depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
     apturl depends on gksu (>= 2.0.0-1ubuntu3); however:
      Package gksu is not configured yet.
     apturl depends on software-properties-gtk; however:
      Package software-properties-gtk is not configured yet.
    dpkg: error processing apturl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of at-spi:
     at-spi depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing at-spi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of baobab:
     baobab depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing baobab (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of checkbox-gtk:
     checkbox-gtk depends on gksu; however:
      Package gksu is not configured yet.
    dpkg: error processing checkbox-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of cheese-common:
     cheese-common depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing cheese-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of cheese:
     cheese depends on cheese-common (= 2.32.0-0ubuntu1); however:
      Package cheese-common is not configured yet.
     cheese depends on gstreamer0.10-plugins-good; however:
      Package gstreamer0.10-plugins-good is not cNo apport report written because MaxReports is reached already
                               No apport report written because MaxReports is reached already
             No apport report written because MaxReports is reached already
                                                                           No apport report written because MaxReports is reached already
                                                         No apport report written because MaxReports is reached already
                                       No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
                                                                                   No apport report written because MaxReports is reached already
                                                                 No apport report written because MaxReports is reached already
                                               No apport report written because MaxReports is reached already
                             No apport report written because MaxReports is reached already
           No apport report written because MaxReports is reached already
                                                                         No apport report written because MaxReports is reached already
                                                       onfigured yet.
    dpkg: error processing cheese (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of compiz-plugins:
     compiz-plugins depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing compiz-plugins (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of compiz-gnome:
     compiz-gnome depends on libmetacity-private0 (>= 1:2.26.0); however:
      Package libmetacity-private0 is not configured yet.
     compiz-gnome depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
     compiz-gnome depends on compiz-plugins (= 1:0.8.6-0ubuntu9); however:
      Package compiz-plugins is not configured yet.
    dpkg: error processing compiz-gnome (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of computer-janitor-gtk:
     computer-janitor-gtk depends on gksu; however:
      Package gksu is nNo apport report written because MaxReports is reached already
     No apport report written because MaxReports is reached already
                                                                   ot configured yet.
    dpkg: error processing computer-janitor-gtk (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgstfarsight0.10-0:
     libgstfarsight0.10-0 depends on gstreamer0.10-plugins-good (>= 0.10.17-1ubuntu1); however:
      Package gstreamer0.10-plugins-good is not configured yet.
    dpkg: error processing libgstfarsight0.10-0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-farsight:
     python-farsight depends on libgstfarsight0.10-0 (>= 0.0.14); however:
      Package libgstfarsight0.10-0 is not configured yet.
    dpkg: error processing python-farsight (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-papyon:
     python-papyon depends on python-farsight; however:
      Package python-farsight is not configured yet.
    dpkg: error processing python-papyon (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libtelepathy-farsight0:
     libtelepathy-farsight0 depends on libgstfarsight0.10-0 (>= 0.0.3); however:
      Package libgstfarsight0.10-0 is not configured yet.
    dpkg: error processing libtelepathy-farsight0 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of empathy:
     empathy depends on libgstfarsight0.10-0 (>= 0.0.1); however:
      Package libgstfarsight0.10-0 is not configured yet.
     empathy depends on libtelepathy-farsight0 (>= 0.0.6); however:
      Package libtelepathy-farsight0 is not configured yet.
    dpkg: error processing empathy (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of telepathy-butterfly:
     telepathy-butterfly depends on python-papyon (>= 0.5.0); however:
      Package python-papyon is not configured yet.
    dpkg: error processing telepathy-butterfly (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of eog:
     eog depends on gconf2 (>= 2.28.1-2); however:
      Package gconf2 is not configured yet.
    dpkg: error processing eog (--configure):
     dependency problems - leaving unconfigured
    dpkg: too many errors, stopping
    Errors were encountered while processing:
     gconf2
     libgnomevfs2-common
     libgnomevfs2-0
     libgnome2-common
     libgnome2-0
     libbonoboui2-0
     libgweather-common
     libgweather1
     libpanel-applet2-0
     gnome-applets-data
     gnome-panel-data
     capplets-data
     libgnomekbd-common
     libgnomekbd4
     metacity-common
     libmetacity-private0
     gnome-settings-daemon
     gnome-control-center
     libgnomeui-0
     python-gnome2
     gnome-about
     gnome-panel
     nautilus-data
     nautilus
     gnome-media-common
     libgnome-media0
     gstreamer0.10-plugins-good
     rhythmbox
     gnome-applets
     yelp
     ubuntu-docs
     aisleriot
     libgksu2-0
     gksu
     software-properties-gtk
     apturl
     at-spi
     baobab
     checkbox-gtk
     cheese-common
     cheese
     compiz-plugins
     compiz-gnome
     computer-janitor-gtk
     libgstfarsight0.10-0
     python-farsight
     python-papyon
     libtelepathy-farsight0
     empathy
     telepathy-butterfly
     eog
    Processing was halted because there were too many errors.
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Last edited by MikeTbob; 10-23-2010 at 07:55 PM. Reason: Added code tags

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,592
    Too much information here. I suppose it's a bit late to ask if you did the recommended system image backup to external drive before you "upgraded" your system into uselessness?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,392
    Make a backup of your and others $HOME, also other datadirectories.
    Then reinstall.

    If your $HOMEs and datadirectories are on separate partitions/discs, you can reinstall without backup, but it is a bit more risky.

    My point is:
    A ubuntu install takes what? 1h, 2h at most.
    Repairing that system might take *much* longer.
    You must always face the curtain with a bow.

  4. #4
    Just Joined!
    Join Date
    Apr 2010
    Location
    Inthe bush somewhere in South Afica
    Posts
    11
    I did not back up system image - lesson number 1! I'll back up my home directory and reinstall. Is there a way I can backup so that I don't have to reinstall all the software I have installed? Next dumb question from newbie...what is the command to reinstall?

    BTW, thanks for quick responses

  5. #5
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,569
    Quote Originally Posted by wtwine View Post
    I did not back up system image - lesson number 1!
    Nearly everybody learns that lesson the hard way. Lesson number 2 is when you are doing your backups; make sure they've worked.

    I had to learn that one the hard way too

    Quote Originally Posted by wtwine View Post
    I'll back up my home directory and reinstall. Is there a way I can backup so that I don't have to reinstall all the software I have installed?
    Unfortunately, that would be the system image

    Quote Originally Posted by wtwine View Post
    Next dumb question from newbie...what is the command to reinstall?

    BTW, thanks for quick responses
    Boot the live CD and install, I don't know if there is a way from a command line but I would suspect not.

    Sorry to be the bearer of bad news.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,592
    Re. Lesson #2 - make sure the backup worked! Good advice. Usually I will run a checksum on the original drive and on the backup image. They should agree.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •