Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    My working but now not working Belkin adapter won't re-build

    A while back I created a driver for my wireless Belkin adapter, and it worked. I got the instructions from here:

    however i have encountered quite a few errors in the re-building of the driver because the kernel on the computer has been updated (which it says at the bottom of the hyper-link)

    this is what I did and the outcome and errors:

    I ran the make file, and got the warning below (lots of them). The code from the include file is:

    #define LIST_CONTAINOR(ptr, type, member) \
    ((type *)((char *)(ptr)-(SIZE_T)(&((type *)0)->member)))

    static __inline void _enter_critical(_lock *plock, _irqL *pirqL)
    spin_lock_irqsave(plock, *pirqL);

    desktop:~/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226$ make
    make ARCH=i386 CROSS_COMPILE= -C /lib/modules/2.6.32-25-generic/build M=/home/bob/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226 modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.32-25-generic'
    CC [M] /home/bob/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/cmd/rtl871x_cmd.o
    In file included from /home/bob/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/cmd/rtl871x_cmd.c:21:
    /home/bob/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100 226/include/osdep_service.h:83: warning: ‘__inline’ is not at beginning of declaration
    Last edited by Spyderkid; 10-24-2010 at 07:28 PM. Reason: Put in include file code that is generating the errors

  2. #2
    Linux User ved's Avatar
    Join Date
    Jan 2008
    New Delhi


    i m not sure about it if you not read this try this
    Take risks: if you win, you will be happy; if you lose, you will be wise.
    New Users : Read This First

  3. #3
    That wasn't of any particular help, sorry.

    I'm try to find out and correct the error:

    /home/bob/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100226/driver/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100226/include/osdep_service.h:93: warning: ‘__inline’ is not at beginning of declaration

  4. $spacer_open
  5. #4
    I've realised that the hperlink i posted didn't work the link is...Samiux's Blog: HOWTO : RealTek 8192SU USB dongle (RTL8192SU) on Ubuntu 10.04


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts