Find the answer to your Linux question:
Results 1 to 3 of 3
I know this question has been asked many times, but I've tried all the solutions and none of them work. The first thing I do is press ctrl-alt-f1. Then I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    3

    How do I exit the x-server so I can install the latest NVIDIA driver?


    I know this question has been asked many times, but I've tried all the solutions and none of them work. The first thing I do is press ctrl-alt-f1. Then I do this:

    Code:
    sudo su
    init 3
    ./NVIDIA-linux-x86-260.19.12.run
    Then it comes up with the error that I have X-server running.

    I've also tried
    Code:
    /etc/init.d/gdm stop
    but that command wasn't recognised. I've also tried
    Code:
    killall -9 X
    but there are no processes called X

    Any help would be appreciated thanks.

  2. #2
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    Do you have the option at boot to do so in failsafe mode ? If you are using grub, you may edit the selected boot option by pressing 'e' and add failsafe to the displayed boot line.
    0 + 1 = 1 != 2 <> 3 != 4 ...
    Until the camel can pass though the eye of the needle.

  3. #3
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    /etc/init.d/gdm stop
    Did you forget sudo /etc/init.d/gdm stop ?

    Then it is alt-ctl-back space to kill the X server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •