Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    issue with stereographics and screen refresh rate


    Hi,
    The default settings for out monitor's refresh rate are not high enough to see stereographics, I need atleast 120 Hz. It is a projector from 'Christie', and it is capable of getting 120Hz vertical & horizontal refresh rate.

    My concern is that 'nvidia-settings' shows a refresh rate of 120Hz. (This
    is what I used to over-ride the xorg.conf under ModeLine).

    For example, I used the command:
    gft 1280 1024 120

    To get 1280x1024 at 120Hz.

    However when I type 'xrandr', or use 'displayconfig-gtk', it shows that
    the current refresh rate is 126Hz, not 120Hz.

    It is possible my 3D glasses are getting refresh rates from different sources that have different refresh rates.

    For example, typing 'xrandr -r 112' works fine, but typing 'xrandr -r 120'
    says, that that resolution is not available for this size.

    Optimally 'xrandr' 'displayconfig-gtk' and 'nvidia-settings' should all
    tell me the same screen refresh rate. They do not.

    I looked in my /etc/X11/xorg.conf and there is no '126' in the file, only
    120. Do you know of any places that linux would be searching to set
    the screen refresh rates to a number that was not set in the xorg.conf?

    I believe that the result of refresh rate difference is the reason why stereographics are not syncing properly with my 3D glasses.

  2. #2
    Linux User ptkobe's Avatar
    Join Date
    Feb 2008
    Location
    Torres Vedras, PT
    Posts
    276
    I don't know anything about stereography

    But I know that X do a search for available modes before using the ones specified at xorg.conf

    check /var/log/Xorg.0.log and see if is there anything that may help you.
    $ cat /var/log/Xorg.0.log |less

    Remember: Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

    So you may start with
    $ cat /var/log/Xorg.0.log |grep '(EE)'
    then cat /var/log/Xorg.0.log |grep '(WW)'
    etc...

    Regards
    Luis

  3. #3
    thanks,
    I did try this and the one error I got was module "type1" not defined. I dont know what this is either.

    I've also tried disabling 'edid-freqs' and 'twinview' mode since other threads have said they can be troublesome when setting your own refresh rate.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •