Find the answer to your Linux question:
Results 1 to 3 of 3
I am new to linux having been persuaded by the enthusiasm of others to go the GNUlinux root..my first impressions are that for all the dissing of Windows at least ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    1

    ubuntu won't play a cd


    I am new to linux having been persuaded by the enthusiasm of others to go the GNUlinux root..my first impressions are that for all the dissing of Windows at least if I stick a CD in the tray it plays....I installed ubuntu 9.04 on a VM running alongside WindowXP and upgraded to 9.10.

    When I open rhythmbox and put a CD in the tray nothing happens..despite the book saying it will play automatically....after much googling I cannot find anything on this problem..most people are trying to stop autoplay. There is not even a cdrom option in the sidepanel of Rhythmbox. I have installed ubuntu-restricted-extras as advised...nada.

    A chat room reply suggested abandon rhythmbox and install vlc which I did...same problem though at least i get an error message "unable to open MRL cdda://dev/sr0". As a complete newbie I do not know what to put int he command line to run rhythmbox or vlc to see the complete error log. Any assistance here much appreciated.

    I have spent two days trying to resolve this problem...the equivalent of several months worth of hanging/freezing on windows

  2. #2
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Hi and welcome Mole1!

    I am new to linux having been persuaded by the enthusiasm of others to go the GNUlinux root..my first impressions are that for all the dissing of Windows at least if I stick a CD in the tray it plays....I installed ubuntu 9.04 on a VM running alongside WindowXP and upgraded to 9.10.
    Is your ubuntu installed wubi or is it installed in a VM such as VirtualBox?

    When I open rhythmbox and put a CD in the tray nothing happens..despite the book saying it will play automatically....after much googling I cannot find anything on this problem..most people are trying to stop autoplay. There is not even a cdrom option in the sidepanel of Rhythmbox. I have installed ubuntu-restricted-extras as advised...nada.
    I'm not sure but if it's installed in VirtualBox, you still have to do some configuration in order for your VM to read a CD or DVD.

    A chat room reply suggested abandon rhythmbox and install vlc which I did...same problem though at least i get an error message "unable to open MRL cdda://dev/sr0". As a complete newbie I do not know what to put int he command line to run rhythmbox or vlc to see the complete error log. Any assistance here much appreciated.
    Very seldom have I personally encountered problems with VLC. I think your VM is not reading your CD tray. But it's just a hunch.

    I have spent two days trying to resolve this problem...the equivalent of several months worth of hanging/freezing on windows.
    If I may suggest, you might find lesser headaches and perhaps enjoy ubuntu more if you install it as a double boot with your XP. I mean if your HD space still allows it. Say...10G partition?
    nujinini
    Linux User #489667

  3. #3
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    you are running in a VM, so you need to make sure that the VM has access to the host CD drive, you will need to set that option (which depends on what V software you're using)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •