Find the answer to your Linux question:
Results 1 to 2 of 2
Ubuntu does not see any hardware RAIDs on this server - Intel confirms that they do not support Debian distros with this onboard SATA controller. Tried going with CentOS and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    12

    External Hard Drive "breaking" software raid 10.10 Server


    Ubuntu does not see any hardware RAIDs on this server - Intel confirms that they do not support Debian distros with this onboard SATA controller.

    Tried going with CentOS and OpenSUSE ... CentOS would install, but wouldn't boot. OpenSUSE would work but after multiple installs, Samba wouldn't start.

    That left us with Ubuntu Server.

    While Ubuntu Server can't see a hardware raid, it can see each of the hard drives individually. From there, I created a software RAID during Ubuntu setup and was able to install.

    Initially had some issues with mdadm "losing" the hot-spare ... was able to fix that by adding sd[abc][12] to /etc/mdadm/mdadm.conf ...

    It worked fine until I plugged a WD MyBook usb hard drive into the machine.

    I lose the hot spare (configured on /dev/sdc) because it mounts the USB hard drive there.

    What I need help with
    I need to be able to make it mount the USB hard drive AFTER mdadm configures /dev/sdc as the 3rd Hitachi hard drive


    What needs to be done to make this work?

    Thanks!

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,175
    The problem is likely due to using the device id (/dev/sdxn) for drives instead of UUID's or volume names/labels to identify them. When you plug in new drives, the device ID's can change, which is why you are having this problem.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •