Find the answer to your Linux question:
Results 1 to 3 of 3
Okay first let me say I am totally new at linux so hopefully people here can keep it simple. Next I will explain several problems I cam having with my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2011
    Posts
    2

    ubuntu live usb boot problem


    Okay first let me say I am totally new at linux so hopefully people here can keep it simple. Next I will explain several problems I cam having with my computer so that people will know where I am coming from. I am unable to boot from my Windows at this point and am trying to get that working. Unfortunately haven't been able to yet. So I am trying linux while trying to fix my windows but haven't been able to get it to boot up from that machine yet. Another problem is that my keyboard seems to cause problems anytime after the computer is past the BIOS sequence and before some sort of operating system loads. It can be any operating system but only after it loads is it a good idea to press a key on the kb. If I press a key before that AND after the BIOS have finished loading then everything freezes. That problem has been around for a long time but my machine was still booting fine for more than a year after it started so it has nothing to do with why my windows isn't working.

    Okay on to the ubuntu boot problem. I am using a USB stick to boot up linux on the computer with a problem. And I tested the stick on another computer that isn't having any problems and it booted fine. I also know that this computer can boot up from a usb stick because I have done it before so that can't be the problem. But the startup o flinux freezes or something after this line.

    loading /casper/initrd.lz..............................ready

    The cursor goes to the next line and just sits there blinking forever. I have tried waiting but that did no good. I have also tried pressing a key to see if it will get any response but it doesn't. I was hoping maybe the keyboard problem would just be with the windows install. Anyway, I have also tried to change the option that it uses to boot up and instead of just running linux from the cd make it install it or go to any of the other options but when I press a key from that screen it simply takes me to a screen that says:
    Boot: with the cursor sitting there blinking. So clearly the keyboard is sending input but I don't know what kind or anything. And any key I press takes me to the same screen I just mentioned. One time it did go to this screen and then it somehow booted up while I was seeing if typing install did anything. I believe I had only typed the i and n but can't be sure. I have tried doing the same thing again but it hasn't done anything. So clearly it can boot up but for some reason I can't get it to. I do have a keyboard that I can plug into the usb slot with a ps2>usb connector it is a laptop btw.

    I would provide more info but not sure what to give. And yes I would restore the computer to factory settings but don't seem to have any cds to do it with not sure if toshiba provided any or not. And although I think there MIGHT be a recovery partition I have tried to get into it multiple times with no success.

  2. #2
    Linux User
    Join Date
    Nov 2008
    Location
    Tokyo, Japan
    Posts
    260
    There are three interesting facts you have mentioned:
    1. Windows doesn't work
    2. Linux doesn't work
    3. A Live USB OS doesn't work, even though that same USB worked on a different computer
    This means you have a hardware problem. If you had a broken hard drive, the Live USB OS would boot fine, but would not be able to detect the disk. However, since this is not the case, and even the Live USB doesn't boot, I would say that you have a bad memory card in your computer.

    It is less likely you have a CPU or motherboard problem; usually when a CPU fails, the computer works as well as a brick, but occasionally the CPU has a bad pin connection or something that causes it to fail sporadically. Also, maybe your keyboard failed and fried something on your motherboard. Maybe you pet your cat and then accidentally shocked your keyboard with static electricity which damaged the motherboard? This is possible, but without more information I am sticking with my first guess -- memory problem.

    I don't know much about Toshiba, but you should be able to jump into the BIOS setup program before boot-up and check how much memory there is. Is there less memory than you expect? Is the BIOS reporting a checksum error, or a bad DIMM, or something to that effect?

  3. #3
    Just Joined!
    Join Date
    Apr 2011
    Posts
    2
    I actually have now been able to boot up from the linux live usb stick. But it took a while to find out how I could. It is not that the problem has disappeared or anything, far from it. But I guess I found a way around it. I found that immediately after the ubuntu screen with the options to boot from the usb, install on the hard drive test the memory etc. comes up the motherboard beeps. If I press a key during that short beep then it will boot up. But if I miss then it won't work. Also if I press a key then it still goes to the screen with the

    boot:

    But after a couple seconds it will continue past that screen to the main screen again go through the countdown again, go to the screen where it loads the two files mentioned earlier. But now after it loads the files and says ready it will boot. However from the time I press the key during the beep the mother board continues the beep until it gets past the last of the stages I just mentioned. So I don't know what problem it is having but it sure is weird. I thought it might be a motherboard problem but after it boots from the usb stick it runs with no problems. I still haven't been able to install linux to the hard disk but at least he can use the computer some now. I am trying to install linux onto it when I can but haven't been successfull yet. I am going to see if it will install fine from a live cd after I burn one. of course after that who knows if I will be able to choose what os to boot from after it gets installed after all these problems. Does anyone know why the motherboard would continue beeping during that time and what component of the motherboard or whole computer might be related to this problem or cause the problem during boot but not affect the normal function of the computer after it boots up into the os?

    Oh and I almost forgot. The bios shows the same amount or possibly just very close to what I would expect. I have two gig and it shows something a little over that. But I know that 2 gig isn't exactly two gig.
    Last edited by dezxter; 04-05-2011 at 07:38 AM. Reason: ad info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •