Hi, I was installing Kubuntu 10.04 and I marked the auto-login option when I was doing the installation, but when I finished it and rebooted to start using the system for the first time, not only the auto-login didn't work but I also ain't being capable of logging through the standard graphical login box, so I have to restart the system in text mode to them enter a "startx" command.
I don't know what it is, because I went to System Settings -> User Management - Advanced -> Login Manager - Convenience and clicked on the "enable auto login" option with my default user name and didn't work. Then i went to /etc/kde4/kdm/kdmrc and saw this:

[X-:0-Core]
AutoLoginEnable=true
so, i don't know why it is not working

No idea also why I cannot login in graphical mode


Also, I like to shutdown the system as normal user, so i went through System Settings -> User Management - Advanced -> Login Manager - shutdown and selected "everybody" for the ' Allow shutdown option'. I also went to System Settings -> Session Manager - General and marked "Offer shutdown options" and in the Session Manager - Default Leave Option I checked "Turn off computer". Again I gave a look In the /etc/kde4/kdm/kdmrc file and saw that in the
[X-*-Core] and [X-:*-Core]
parts of the file, the lines "AllowShutdown=All" were present. Finally I changed the owner of reboot and shutdown from the root to my user, but he keeps wondering about the root password.

Bay the way, what is the difference between
[X-*-Core]
and
[X-:*-Core]
. The second one is the one that it is modified when I selected "everybody" for the "Allow shutdown option'. So the first one would be a king of a backup's configuration?


Thanks for the effort