Find the answer to your Linux question:
Results 1 to 6 of 6
I'm on Windows 7 at the moment, but I have Ubuntu on my computer as well. Everything was working fine until I tried to start up after shutting down last ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    3

    Can't Boot Ubuntu (Newbie Question, Please Help)


    I'm on Windows 7 at the moment, but I have Ubuntu on my computer as well. Everything was working fine until I tried to start up after shutting down last night. I now get the following error message when trying to start up Ubuntu:

    "init: ureadahead-other main process (474) terminated with status 4
    init: udevtrigger main process (611) terminated with status 1
    init: udevtrigger post-stop process (614) with status 1
    init: udevmonitor main process (610) killed by TERM signal

    The disk drive for / is not ready yet or not present
    Continue to wait, or press S to skip mounting or M for manual recovery."

    If I try to do manual recovery, it gives me a terminal command line which I don't know what to do with (I'm new to Linux). The numbers in parentheses are different every time I try this, but the message always remains the same.

    Can someone help me to get Ubuntu up and running again?

    Thanks,

    James

  2. #2
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,204
    From Ubuntu Developer keybuk.

    For

    "init: ureadahead-other main process (474) terminated with status 4
    He says

    ureadahead exits with status 4!

    This isn't actually a bug

    Status 4 (usually ureadahead-other exits with this) means that you had a mountpoint in your fstab that didn't have any files on it needed during boot. Probably that drive with all those MP3s and movie files on it.

    It still reads everything needed during boot, the status is just there for me to debug other issues.

    The real bug here is that Upstart spams the console with that message, even though the ureadahead-other.conf file has "normal exit 4" in it!

    (In other words, If your boot fails, this message is completely unrelated to that! It's more likely that there is an issue with the X server starting, or an issue with init scripts not being run -- a good clue might be whether you see a login: screen after pressing Alt+F2)
    from All about ureadahead - Ubuntu Forums

    For your other errors. I havbe no Idea other than boot up your live cd of Ubuntu and open gparted and look and see if Ubuntu partition is full. If so or not even so. Unmount partition while running live cd with a right click. After unmounting right click again in gparted and do a check. It will do a fdisk check on the Ubuntu partition and correct any file system errors. When done. Close Gparted. Shut down from live cd. Take out cd. See if it boots. Thats all I can think of doing.

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    3
    Okay. I don't have an Ubuntu cd. I downloaded it and installed it. As far as I can tell, there are just three options which it gives me: to wait (which will probably achieve nothing), to hit "S" (which is not really an option since skipping the mount brings up a black screen), and to hit "M" for a "Manual Recovery".

    I know very little about Linux but would like to get my Ubuntu running again (obviously). I have a bunch of files on that side of my computer, and I was just starting to enjoy using the OS. I'm thinking that the error is related to upgrading versions (which I just did).

    Is there anything else I can do from the root@ubuntu: ~# console which might troubleshoot this problem? It seems like I (presumably) have access to everything but can't get the GUI to start. I have really no experience navigating from the CLI. I tried some other stuff but nothing worked (CTRL+ALT+F7 crashes it).

    Thanks,

    James

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,204
    I downloaded it and installed it
    Is this a wubi install?

    If so. I can only suggest maybe typing mc to open Midnight Commander File Manager at the # prompt and see if it opens(you might not have it installed though). You can access Ubuntu files from there maybe but I am not a wubi type of guy. Wubi installs are just a folder installed inside of Windows in a program folder named Ubuntu.

    Wubi installs are different than a partition install. So I have no experience with how to fix those.

    poke and hope link

    How To Repair Ubuntu Netbook After Upgrade Problem (WUBI)

    [SOLVED] Wubi upgrade to Natty Narwhal - Ubuntu Forums

    [wubi] Wubi megathread - Ubuntu Forums

  6. #5
    Just Joined!
    Join Date
    May 2011
    Posts
    3
    It is a Wubi install. For some reason I was under the impression I had partitioned my drive but it's as you said, there is an Ubuntu folder inside Windows' Program Files. It sounds like that's less stable for some reason. I'll take a look at the links you posted.

  7. #6
    Just Joined! Miykel's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    60
    G'Day I have a Wubi installed on my PC and it's on a partition of it's own, when you begin to install have a look at the top LH sid of the install option window and you will see a button with the drive letter into which Ubuntu will be installed, if you click on this button it will give you a drop down menu of possible partitions for installation, I formated a 100Gb partition named it Ubuntu and just to be sure gave it U letter (lol),
    It's realy good especially if, like me you are new to Linux, when you blow it, it doesn't take long to boot into Windows, delete and format the partition and reinstall, less than 1/2 hour., I was thinking of writting a batch file to do the whole thing I was reloading it so often at the begining. If you have the install inside windows, it would be a good idea to delete the whole file as it is about 20Gb, BTW, I, for some reason have to put a blank DVD into the rom drive, but it never gets used ????. if you don't it will say "no disk in drive".
    Regards Miykel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •