Find the answer to your Linux question:
Results 1 to 7 of 7
Hi I have ntfs partition installed bran new ubuntu system. I have some problem with unrar utf8 character zip files.Then i change my fstab file that uses files in D:\ubuntu\disks\root.disk ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    middle Asia
    Posts
    81

    [SOLVED] fstab mess


    Hi
    I have ntfs partition installed bran new ubuntu system. I have some problem with unrar utf8 character zip files.Then i change my fstab file that uses files in D:\ubuntu\disks\root.disk and i added with out no fearless
    Code:
    ,utf8
    and after all now i can't boot my linux system it does not allow me to change anything in fstab file. Although i use as a prefix sudo or as a root "sudo -i" commands I dont have any right to change it.
    What should i do now???

    Thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,111
    and i added with out no fearless
    That makes absolutely no sense in the context? You first say you change your fstab file and later in the same sentence say that you can't make any changes to fstab and can't boot. So which is it? Were you able to boot before making a change to fstab? Can't boot after the change? Did you make a change? If so, what was it?

    From your comments, it appears you do not have an actual Ubuntu installation but a wubi folder inside windows, is that right?

    What was the problem with rar files and what did you do?

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    middle Asia
    Posts
    81
    Quote Originally Posted by yancek View Post
    That makes absolutely no sense in the context? You first say you change your fstab file and later in the same sentence say that you can't make any changes to fstab and can't boot. So which is it? Were you able to boot before making a change to fstab? Can't boot after the change? Did you make a change? If so, what was it?

    From your comments, it appears you do not have an actual Ubuntu installation but a wubi folder inside windows, is that right?

    What was the problem with rar files and what did you do?
    Hi yancek
    I did that process before that problem happened.Now im not able to do anything. I mean i have to be careful when i try some thing with fstab file. it could be very dangerous.

    Lets come to Rar file problem. I have rar file in this file there is a file with other language character encoding.Thats why it gives error.And i could extract that file in windows.

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,111
    Do you have unrar installed?
    What is the filename and where is it located on your computer?
    What is the command you use? and what is the specific error you get?

    Open rar file or Extract rar files under Linux or UNIX

    I'm not familiar with rar files so I doubt if I'll be able to help.

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    middle Asia
    Posts
    81
    Quote Originally Posted by yancek View Post
    Do you have unrar installed?
    What is the filename and where is it located on your computer?
    What is the command you use? and what is the specific error you get?

    Open rar file or Extract rar files under Linux or UNIX

    I'm not familiar with rar files so I doubt if I'll be able to help.
    Thanks
    But first of all.
    I need to open ubuntu desktop.I have to fix this /etc/fstab mess.As i told u.Im no longer able to load gnome desktop. I have to change back to fstab old properties.But im not longer able to get root authorization.
    Code:
    sudo gedit /etc/fstab
    sudo mc
    sudo nano -w /etc/fstab
    it wont let me be a root user to change this file.
    sudo -i (to became #) either dont work.

    Im stuck now .

  6. #6
    Just Joined!
    Join Date
    Nov 2004
    Location
    middle Asia
    Posts
    81
    /etc/fstab
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    nodev,noexec,nosuid 0       0
    /host/ubuntu/disks/root.disk /               ext4    loop,errors=remount-ro,utf8 0       1
    /host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
    and during boot process it gives this error message
    Code:
    An error occurred while mounting /
    Press S to skip mounting or M for manual recovery
    But this time system loads with read only mode

  7. #7
    Just Joined!
    Join Date
    Nov 2004
    Location
    middle Asia
    Posts
    81

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •