Find the answer to your Linux question:
Results 1 to 5 of 5
I am trying to ssh a remote box from putty but I am getting following error. "No supported authentication methods available" I don't have access to the server so I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    6

    ssh problem


    I am trying to ssh a remote box from putty but I am getting following error.

    "No supported authentication methods available"

    I don't have access to the server so I must have make my ssh client compatible to ssh server.

    This is the trace from another client

    [SSH] Protocol Version 2 (OpenSSH_5.3p1 Debian-3ubuntu6)
    [SSH] Cipher: aes128-ctr
    [SSH] FAIL: Unable to authenticate
    [SSH] INFO: DISCONNECT

    How can I fix it?

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,378
    *Assuming* you have an account on that box, then you were also given a way to authenticate.
    username/password or a private key or ..

    Try these ways, and if they fail, then thatīs it.
    You will then need to contact the admin of that server and ask for new credentials.


    As a sidenote:
    If you have a openssl keyfile, then this would need to be converted to putty first with puttygen
    You must always face the curtain with a bow.

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    3

    ssh problem

    Based on the error msg, try to connect to the server using
    different "connection type", i.e.
    either "telnet" or "rlogin".
    The default connection type is "ssh", which is secure and
    hence preferred.
    Good luck!

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    13
    Hi,
    As per the error message "No supported authentication methods available" I think the certificate you are using to connect the server is not correct.

  5. #5
    Just Joined!
    Join Date
    Jan 2011
    Location
    Fairfax, Virginia, USA
    Posts
    94
    Hi, I think I've experienced what you are seeing. Openssh requires some kind of encryption from the client to server. You can't turn it off as far as I know. Following the asymmetric portion of your connection, random numbers are generated for faster symmetric algorithms (for instance AES). Prior to this pivot, both ends have to agree on algorithms to use. If they cannot agree on an algorithm, you'll see a message like this.

    In my case, this happened because I limited my ciphers in /etc/ssh/sshd_config to:
    Ciphers aes256-cbc
    and I tried to connect with an older client that did not have this algorithm.

    Another possibility is that the server is configured to use only PubkeyAuthentication and PasswordAuthentication is disabled. Have a look in /etc/ssh/sshd_config and expect to see a line that look like this:
    PasswordAuthentication yes
    If that line says "no", then it looks like you need to construct a public and private key for this host
    Last edited by BrianMicek; 06-09-2011 at 11:52 AM. Reason: augmentation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •