Find the answer to your Linux question:
Results 1 to 8 of 8
I'm trying to install Postfix on my Ubuntu 10.4 using help.ubuntu.com/community/Po...asicSetupHowto I'm following the instruction closely. When I test my default installation using telnet localhost 25, I get the following: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    55

    Postfix


    I'm trying to install Postfix on my Ubuntu 10.4 using
    help.ubuntu.com/community/Po...asicSetupHowto

    I'm following the instruction closely. When I test my default installation using telnet localhost 25, I get the following:

    telnet localhost 25
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    Connection closed by foreign host.

    Please help me out ! What have I done wrong ?

    Amanda

  2. #2
    Linux Newbie nplusplus's Avatar
    Join Date
    Apr 2010
    Location
    Charlotte, NC, USA
    Posts
    106
    Have you defined "mynetworks = 127.0.0.0/8" or "mynetworks = 127.0.0.1/32"?

    N

  3. #3
    Just Joined!
    Join Date
    Jul 2011
    Posts
    55
    Quote Originally Posted by nplusplus View Post
    Have you defined "mynetworks = 127.0.0.0/8" or "mynetworks = 127.0.0.1/32"?

    N
    I use the default 127.0.0.0/8. I don't know the difference
    Amanda

  4. #4
    Linux Newbie nplusplus's Avatar
    Join Date
    Apr 2010
    Location
    Charlotte, NC, USA
    Posts
    106
    Either one should be fine. What about your "inet_interfaces" parameter. By default, it should be set to "= all", which should work, but it might be worth checking. If it is not set to all, try setting it to that, restarting Postfix, and trying again.

    N

  5. #5
    Just Joined!
    Join Date
    Jul 2011
    Posts
    55
    Quote Originally Posted by nplusplus View Post
    Either one should be fine. What about your "inet_interfaces" parameter. By default, it should be set to "= all", which should work, but it might be worth checking. If it is not set to all, try setting it to that, restarting Postfix, and trying again.

    N
    hi nplusplus, this is my main.cf:

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = no

    # TLS parameters
    smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = luckyseven-desktop
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mydestination = luckyseven-desktop, localhost.localdomain, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    home_mailbox = Maildir/
    mailbox_command =

  6. #6
    Just Joined!
    Join Date
    Jul 2011
    Posts
    55
    I can now do telnet localhost 25 and it works as described in the guide.
    Now I come to: "Adding your local domains to postfix". How can I configure mydestination
    In the guide, it says:
    sudo postconf -e "mydestination = mail.fossedu.org, localhost.localdomain, localhost, yourdomain.com"

    Amanda

  7. #7
    Linux Newbie nplusplus's Avatar
    Join Date
    Apr 2010
    Location
    Charlotte, NC, USA
    Posts
    106
    Do you know what you did to fix your original problem?

    As far as adding local domains, I have never used the postconf -e method. I normal just edit main.cf and reload/restart (depending on what is recommended in the postfix documentation).

    For more general help, you might check out The Postfix Home Page.

    N

  8. #8
    Just Joined!
    Join Date
    Jul 2011
    Posts
    55
    Do you know what you did to fix your original problem?
    I'm not very sure how.

    and How can I identify my local domain name ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •