Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I'm trying to use my usb wireless LAN dongle (Senao sub362-EXT)under Backtrack 5 using ndiswrapper. I already installed ndiswrapper using following command: rootadbt:~# apt-get install ndiswrapper-common Reading package lists... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    12

    Command ndiswrapper not working


    Hi,

    I'm trying to use my usb wireless LAN dongle (Senao sub362-EXT)under Backtrack 5 using ndiswrapper.

    I already installed ndiswrapper using following command:

    rootadbt:~# apt-get install ndiswrapper-common
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libdmraid1.0.0.rc16 python-pyicu libdebian-installer4 cryptsetup
    libecryptfs0 reiserfsprogs rdate bogl-bterm ecryptfs-utils libdebconfclient0
    dmraid keyutils
    Use 'apt-get autoremove' to remove them.
    Suggested packages:
    ndiswrapper-source
    The following NEW packages will be installed:
    ndiswrapper-common
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 21.7kB of archives.
    After this operation, 98.3kB of additional disk space will be used.
    Get:1 [xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx]Index of /[] revolution/main ndiswrapper-common 1.54-2ubuntu1 [21.7kB]
    Fetched 21.7kB in 0s (49.6kB/s)
    Selecting previously deselected package ndiswrapper-common.
    (Reading database ... 212075 files and directories currently installed.)
    Unpacking ndiswrapper-common (from .../ndiswrapper-common_1.54-2ubuntu1_all.deb) ...
    Processing triggers for man-db ...
    Setting up ndiswrapper-common (1.54-2ubuntu1) ...

    As far as I can see is the install successful.

    However when I use ndiswrapper on the command prompt I get following error message:

    rootadbt:~# ndiswrapper
    Error: unable to find a version of ndiswrapper!

    It seems that it is not installed properly or something.

    Does anybody know how to fix this problem?

    Thanks already!!

    Raka.

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,206
    You need to install the package ndiswrapper-source, which contains the source code for ndiswrapper itself, then build it against your kernel. To do this, you'll need the kernel headers as well if you haven't already got them.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    12
    I'm not so experienced with Linux , unfortunately.

    You have to help me out with more detailed commands.

    However I tried already following command:

    root(ad)bt:~# apt-get install ndiswrapper-source
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package ndiswrapper-source is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package ndiswrapper-source has no installation candidate

    It seems the package is missing.
    Do you have any idea how I can install it?

    Kind regards,Rata.

  4. #4
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,206
    Tricky! But I found this link which might help you.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  5. #5
    Guest
    Join Date
    Feb 2005
    Posts
    312
    Sure you need ndiswrapper? Have you tried identifying the chipset with lspci or lsusb?

  6. #6
    Just Joined!
    Join Date
    Jan 2009
    Posts
    12
    I downloaded ndiswrapper 1.57rc1 from sourceforge.net and installed it. I got no errors what so ever and ndiswrapper is now recognized as a command

    However a next issue pops up immediately.

    When I search the net for ways to install the windows drivers they all speak of using ndiswrapper 1.6. Way back thus!!

    Also the subcomand menu changed.There are other -x values used than there are mentioned in the description.

    Here is the description:

    By using the ndiswrapper v1.6 driver in linux you can load the windows driver and bootloader.

    These steps worked for us with FC4 i386 on a Compaq M2000 laptop with A64 cpu they will be different for other distributions and hardware.



    You must install the kernel source.

    Download build and and install version 1.6 or later of the ndiswrapper here

    You will need the eub-362 drivers and bootloader files here

    install the eub driver with the command

    ndiswrapper -i net5523.inf

    plug in your eub-362

    modprobe ndiswrapper

    cat /proc/bus/usb/devices note the vendor id and product id

    tell ndiswrapper to use the driver on the eub-362

    vendorid

    serial number

    ndiswrapper -d 0cf3:0001:0.01



    load the bootloader (put this step into your startup it must be issued each time the eub is inserted)

    vendor id

    prodid

    load_fw_ar5523 ar5523.bin 0cf3 0002



    bind the eub362 to wlan0

    ndiswrapper -d wlan0 net5523



    Issue iwconfig command you should now see the eub362 as wlan0 and can configure in the usual way.

    !!!Subcommand -d is not implemented in version 1.57rc1

    Here are the menu options for version 1.57rc1:

    root(ad)bt:~# ndiswrapper
    install/manage Windows drivers for ndiswrapper

    usage: ndiswrapper OPTION
    -i inffile install driver described by 'inffile'
    -a devid driver use installed 'driver' for 'devid' (dangerous)
    -r driver remove 'driver'
    -l list installed drivers
    -m write configuration for modprobe
    -ma write module alias configuration for all devices
    -mi write module install configuration for all devices
    -v report version information

    where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
    as reported by 'lspci -n' or 'lsusb' for the card

    And I cannot find an updated description of how to install the windows drivers under the latest version 1.57rc1.

    Does anybody know them by chance?

    Would be a great help!!

    Greetings,Rata.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •