Hello everyone,

I hope someone nice knows how to fix this..

I'm trying to connect a bluetooth mouse using blueman, v. 1.21

Problem seems to be bluetoothd not running at startup, so blueman refuses to start, only a dialog appears: "Bluez daemon is not running, blueman-manager cannot continue."

On my system, bluetoothd will run only as root (sudo), so my current workaround is simply to sudo bluetoothd manually, but id like to fix it so it starts by itself.

If i try to start bluetoothd as non-root it reports:

Code:
Bluetooth deamon 4.91
Unable to get on D-Bus
In the startup scripts i found the same bluetoothd script in all runlevels and init.d:

Code:
DAEMON=/usr/sbin/bluetoothd
test -f /usr/sbin/bluetoothd || exit 0
#  bluetoothd normally starts up by udev rules.  it needs dbus to function,
log_progress_msg "bluetoothd"
pkill -TERM bluetoothd || true
log_progress_msg "bluetoothd"
I looked in /etc/udev/rules.d/ but no reference to bluetoothd.

Further i have already tried with no luck:

1. Editing /etc/dbus-1/system.d/bluetooth.conf to include my user (essentially copying the part that was for root):

Code:
<policy user="myuser">
    <allow own="org.bluez"/>
    <allow send_destination="org.bluez"/>
    <allow send_interface="org.bluez.Agent"/>
</policy>
I tried it while both keeping the root policy and without, still, no luck!

2. Editing /etc/pam.d/common-session and /etc/pam.d/gdm to include the line:

Code:
session optional pam_ck_connector.so
In the case of common-session it was already there but with a "nox11" which i tried removing. No luck no luck.

Btw, I'm confused as to which session manager I'm using, since i have both xfce4-session and gdm-session-worker running.

Anyways, hope someone is savvy enough to figure it out or bring some hints, otherwise i sincerely apologize for wasting your time! I'll sign off with uname -a:

Code:
Linux mycompname 3.0.0-9-lowlatency #12ppa1~natty1-Ubuntu SMP PREEMPT Mon Aug 22 06:52:15 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Peace