Find the answer to your Linux question:
Results 1 to 8 of 8

Thread: Power issues

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Power issues

    Hey guys, i was wondering if someone here can help me. I posted this same thing on the "official" ubuntu forums yesterday and absolutely no one responded, this is even after I bumped it several times today and commented about how horrible the support was. Anyway, im just going to copy and paste the same thing and maybe someone here could assist me as I would be really, really, really greatful. Here it is...

    Hey guys, I have a quick question and I have tried to search the forums, even Google, but could not find exactly the same as this problem.

    I recently just tried to install Ubuntu (dual boot Windows 7) on my main PC since I had it on my laptop for ages and love it. Everything installed and went perfect however I seem to be having major Power management issues.

    1) When I login past the login screen it seems to shut down my monitor completely for several minutes eventually waking up to the desktop.

    2) For some reason when I go to put it into standby, It will not wake up at with the mouse and keyboard, only my hitting the power button. In Unity 2d it seems to freeze after several minutes and will not wake up. In Unity 3D, it always freezes and the only way to recover is by doing a hard reset.

    3) I just realized also that after several minutes of regular computer use(maybe like 15-30)it just seems to shut down too and require a hard reset. (am typing this from Windows installation)

    I am sure that there is other problems too and all of it seems to do with power management. I already updated my graphic card drivers to the latest and installed all the updates. If anyone could help i would be really appreciative!

  2. #2
    ok, 141 views and no one here has responded yet either?

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Well, there have been some major regressions in power management in recent Linux kernels. This is undoubtedly your problem. It has to do with how the Active State Power Management (ASPM) support works. There have been some fixes and how-to's posted to reduce the problem, although I don't think it is entirely resolved as yet. I will see if I can find some references to this for you, but in the mean time you might want to do some Google searching on your own. Here is a link that may help shed some light on the subject and provide some links to help resolve the issue: New Kernel Patch Slashes Linux's Power Appetite | PCWorld Business Center
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
  5. #4
    U could try the acpi off command in your grub boot line. I've currected issues in the past with this command. The thing to remember though is that it will disable some of your power management options

    P.S. you should be a little more patient when posting. Sometimes it takes a little bit to get the response you need.

  6. #5
    Linux User ptkobe's Avatar
    Join Date
    Feb 2008
    Torres Vedras, PT
    From your description, it would help forum users (and then again may not) to know what is your motherboard, bios and graphic card. You gave the symptoms, but no other potentially helpful info, and if you don't, how can anyone help you? Put yourself in their position. I know you are using windows 7, but not even what ubuntu version you have.

    Your problem may be a power management issue, but the login delay makes no sense in that scenario, in my opinion. It may be an hardware issue, or maybe a bad ubuntu installation, or something else I'm not thinking of.

    So, have you tried to uninstall windows 7? (just a joke, sorry). I think the acpi suggestion is a good place to start. But if it was me, I would try another graphic card and see what happens first. Maybe you can do that, I don't know.

  7. #6
    Thanks guys for your replys, im going to try the acpi off tonight when I get home from work and see if it makes a difference.

    Sorry about the comment, its just very frusterating because i just looked at my other posts that are still on the other forum and there are still no replys! Ton of views but no replys. Anyway, thanks for your suggestion and ill try it later.

  8. #7
    Also you could try this kernel parameter:

    vga=normal nomodeset
    also check out /var/log/messages and the output of dmesg for hints/clues.

  9. #8
    Thanks guys for your help but i figured it out! I downloaded an app called grub settings manager or something (forgot the link) and found out that grub by default had a screen resolution of 620x420. The app let me change itto the 1025x780 or something and now it works perfectly! Not sure if that is a bug but should be a little better documented for newbies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts