Hi,

I am getting the following warning message from mail.log on ubuntu server 10.04.

testserver1 postfix/pickup[26644]: AA27A2BE0055: uid=0 from=<root>
testserver1 postfix/cleanup[26742]: AA27A2BE0055: message-id=<20111120230022.AA27A2BE0055(at)testserver1>
testserver1 postfix/qmgr[1422]: AA27A2BE0055: from=<root(at)testserver1>, size=1588784, nrcpt=1 (queue active)
testserver1 postfix/local[26744]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
testserver1 postfix/local[26744]: AA27A2BE0055: to=<root(at)testserver1>, orig_to=<root>, relay=local, delay=21, delays=21/0.02/0/0.16, dsn=2.0.0, status=sent (delivered to mailbox)
testserver1 postfix/qmgr[1422]: AA27A2BE0055: removed

I wonder if anyone might be able to explain why the root is trying to send to itself.

The other thing is I realized that I use alias in main.cf as follows
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = ipv4
local_recipient_maps = ldap:/etc/postfix/ldap-users-auth.cf
mail_spool_directory = /var/spool/mail
mailbox_size_limit = 0
mydestination = localhost.$mydomain,localhost,$mydomain,$myhostnam e
mydomain = example-com
myhostname = testserver1
mynetworks = 127.0.0.0/8
mynetworks_style = subnet
readme_directory = no
recipient_delimiter = +
relayhost =
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination,reject_sender_login_mismatch
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = mycompany-com
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
virtual_alias_maps = hash:/etc/postfix/valias
virtual_gid_maps = static:106
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = mycompany-com
virtual_mailbox_maps = hash:/etc/postfix/virtual_mailboxes
virtual_minimum_uid = 100
virtual_transport = dovecot
virtual_uid_maps = static:106

My question is whether or not I need to define NIS or perhaps disable it.

Any help would be greatly appreciated.

Thank you in advance