Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I'm trying to install a game and get this error: I'm running Ubuntu 11.10 and running intel pent 2.8 ghz x 2 64 bit. The setup program seems to have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2011
    Posts
    7

    Getting this error when trying to install a game.


    I'm trying to install a game and get this error: I'm running Ubuntu 11.10 and running intel pent 2.8 ghz x 2 64 bit.

    The setup program seems to have failed on x86_64/unknown


    Detecting libc...
    Detected: os=Linux, arch=x86_64, libc=unknown



    Thanks in advance for any help.

    ou8it

  2. #2
    Just Joined!
    Join Date
    Nov 2011
    Posts
    7
    More info from terminal:

    tyler@ubuntu:~$ ./ThinkTanks_v1.1.sh.bin
    Verifying archive integrity... All good.
    Uncompressing ThinkTanks............................
    This installation doesn't support unknown on Linux / x86_64
    (tried to run setup.gtk)

    This installation doesn't support unknown on Linux / x86_64
    (tried to run setup)


    The setup program seems to have failed on x86_64/unknown


    Detecting libc...
    Detected: os=Linux, arch=x86_64, libc=unknown
    tyler@ubuntu:~$


    This game installs on Ubuntu 8.10. Do I need to revert back to that?

    Thanks
    ou8it
    Last edited by ou8it; 12-01-2011 at 12:49 AM. Reason: left out information

  3. #3
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    I guess the program was compiled under a 32bit version of glibc and that is not found on your 64-bit system. If that's the case, maybe there is a 32-bit version of glibc that you can install under Ubuntu via apt-get? I don't know, not a regular Ubuntu user...

  4. $spacer_open
    $spacer_close
  5. #4
    Banned
    Join Date
    Nov 2011
    Location
    India
    Posts
    29
    Me too feels that this is because of architecture (64bit)


    Thanks,
    Manoj
    Last edited by MikeTbob; 12-01-2011 at 12:07 PM. Reason: removed redirect

  6. #5
    Just Joined!
    Join Date
    Nov 2011
    Posts
    7
    maybe there is a 32-bit version of glibc that you can install under Ubuntu via apt-get?
    I'm quite new at linux. what would the exact command be that I enter in the terminal to find that glibc?

    Thanks
    Frank

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    I don't know the command line fu, but I think there is the notion of multilib in Ubuntu - any Ubuntu pros out there who can shed some light?

  8. #7
    Just Joined!
    Join Date
    Nov 2011
    Posts
    7
    I found this info but not sure if this is my answer.


    How to compile a 32-bit application using gcc on the 64-bit Linux version

    by Vivek Gite on December 13, 2006 22 comments

    I had to compile a 32-bit application using GNU gcc on the 64-bit version Linux.

    Luckily gcc man page directed me to -m32 and -m64 option. These options generate code for a 32-bit or 64-bit environments.

    => The 32-bit environment sets int, long and pointer to 32 bits and generates code that runs on any i386 system.

    => The 64-bit environment sets int to 32 bits and long and pointer to 64 bits and generates code for AMD's x86-64 architecture.

    You can pass -m64 or -m32 as follows
    For 32 bit version:
    $ gcc -m32 -o output32 hello.c
    For 64 bit version :
    $ gcc -m64 -o output64 hello.c

    And output is :
    $ ./output32
    Output:

    Long int size is 4 bytes long!

    Now let us see 64 bit output:
    $ ./output64

    Long int size is 8 bytes long!

    Sample code - hello.c:

    #include <stdio.h>
    int main(){
    long z; printf("Long int size is %i bytes long!\n", sizeof(z)); return 0;
    }

  9. #8
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    I think you just want to just run the game, though, not actually compile it, right? It has already been compiled, I guess, against the 32-bit version of (g)libc.

    If multilib glibc is not possible, is running a VM on your Ubuntu box a possibility? You could install a 32-bit version of Ubuntu (or whatever) and run it in that. Seems like overkill though...

    Edit: Another thought - run a command to show the libraries that the executables have been compiled against. Cd into the directory where you uncompressed the game and run:
    Code:
     find. -type f -iname 'setup*' -printf "\n%p:\n" -exec ldd {} \;
    You can post that output here.
    Last edited by atreyu; 12-02-2011 at 01:51 PM. Reason: show libs

  10. #9
    Just Joined!
    Join Date
    Nov 2011
    Posts
    7
    I run dedicated game servers and linux may be the answer to the lag problems i have with windows.

    Output from "find" command above. Not sure if I ran that right , The setup installer is named Thinktanks_v1.1.sh.bin




    tyler@ubuntu:~$ cd /home/tyler
    tyler@ubuntu:~$ cd /home /tyler
    tyler@ubuntu:/home$ find. -type f -iname 'setup*' -printf "\n%p:\n" -exec ldd {} \;
    No command 'find.' found, did you mean:
    Command 'find' from package 'findutils' (main)
    Command 'findv' from package 'polylib-utils' (universe)
    find.: command not found
    tyler@ubuntu:/home$

  11. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by ou8it View Post
    tyler@ubuntu:/home$ find. -type f -iname 'setup*' -printf "\n%p:\n" -exec ldd {} \;
    No command 'find.' found, did you mean:
    You need a space after the find in that command (find is a binary program located in /usr/bin or /bin probably). cut-and-pasted, to be sure.

    btw, when you run that installer (by putting a ./ in front of Thinktanks_v1.1.sh.bin), I am guessing the first thing it is doing is extracting a bunch of files to the current working directory (amongst them "setup.gtk", e.g.). Is this true, can you tell?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •