Find the answer to your Linux question:
Results 1 to 7 of 7
Hello all. VERY new to Linux and I'm finding the learning cover to be pretty massive. hope you can help me out with what should be a very simple task ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    9

    Secondary HD install


    Hello all. VERY new to Linux and I'm finding the learning cover to be pretty massive. hope you can help me out with what should be a very simple task I'm sure. I built a cpu to use as a "Ghetto" server as it were for media files and back-ups etc. it's linked into my home network which is primarily windows based and has been working very well for about a year now. I ran out of hd space the other day and decided to pick-up a 1tb internal drive to add to the system. I have installed the drive physically and the system acknowledges it's presence but that's about it. When i run a system monitor it still shows my HD at 98% capacity. I did some reading and followed a tutorial on how to mount the drive through terminal etc and now the machine wont boot properly. I'm required to hit control s to avoid that drive in the boot up sequence i guess. any way, as i say, what should have been a dead easy two minute upgrade has turned into a serious pain in the....... is there a step by step sticky on this for a complete "newbie" such as myself? The one I followed previously was from Ubuntu / Linux support i believe. thanx!

  2. #2
    Just Joined!
    Join Date
    Dec 2011
    Posts
    9
    also tried this process and still no joy? can't be this complicated.... this is nut's.

    ww.mikestechblog.com/joomla/operating-systems-section/operating-systems-ubuntu/53-add-a-second-hard-drive-in-ubuntu.html

  3. #3
    Just Joined!
    Join Date
    Dec 2011
    Posts
    9
    decided to scratch the terminal approach and went to the menu driven method. it's now giving an error message saying i can not mount the drive, only root can. I only have one user set up on that machine and I'm pretty sure it has root authority. Anyone have any suggestions?.... please..... anyone?

  4. #4
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    You are not operating with root privilege normally. In the terminal,
    you precede commands with the word sudo and it asks for
    your password, and the command runs as root.

    Administrative programs you find in the system menu should also ask
    for your password. To edit system configuration files, you have to
    invoke your text editor with sudo.

    Have you formatted the new drive? Is it ready to use?

  5. #5
    Just Joined!
    Join Date
    Dec 2011
    Posts
    9
    I have gotten through the install, formatting and partitioning to this point and I thought i had it mounted at one point as well but it would appear not. i followed the directions on a permanent mount but ran into an issue at boot up so i have obviously screwed some thing up there..... at least.

  6. #6
    Just Joined!
    Join Date
    Dec 2011
    Posts
    9
    to date i have managed to install the drive partition it and manually mount it. I have not been able to get a permanent mount to work as yet. when i pull up system monitor the drive shows up how ever under the system tab it still only reflects my system as having 2 gigs of storage space available which should be more like 872 gigs given the new drive. any help would be GREATLY appreciated.

  7. #7
    Linux User ptkobe's Avatar
    Join Date
    Feb 2008
    Location
    Torres Vedras, PT
    Posts
    276
    Hi, pimpn

    IMO, terminal is the right approach.

    To make the mount permanent you must edit the file /etc/fstab. See man fstab. Making it simple you'll have to add one (or more) line with
    /dev/sdbN /mount/dir fstype defaults 0 0
    (replace on this line with the parameters you use on your mount command). Use nano or other text editor to do it, as sudo, like in
    $ sudo nano /etc/fstab

    type on a terminal:
    $ sudo df -h
    to see your disk free space, and post the output, if you wish.

    Ask again if you didn't understand something. I'll try to explain better. Regards
    Luis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •