Find the answer to your Linux question:
Results 1 to 7 of 7
Hello there. I do: Code: $ ps -ef | grep mysql kingoslo 9188 9125 0 13:57 pts/0 00:00:00 grep --color=auto mysql $ sudo service mysql start And it doesn't start. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    39

    mySQL: The error log says this. (And mysql will not start)


    Hello there.

    I do:

    Code:
    $ ps -ef | grep mysql
    kingoslo  9188  9125  0 13:57 pts/0    00:00:00 grep --color=auto mysql
    $ sudo service mysql start
    And it doesn't start.

    I checked error log. This is repeated over and over hundreds if not throusands of times:


    Code:
    111218 14:17:44  InnoDB: Starting shutdown...
    111218 14:17:49  InnoDB: Shutdown completed; log sequence number 0 44233
    111218 14:17:49 [Note] /usr/sbin/mysqld: Shutdown complete
    
    111218 14:18:14 [Note] Plugin 'FEDERATED' is disabled.
    111218 14:18:14  InnoDB: Initializing buffer pool, size = 8.0M
    111218 14:18:14  InnoDB: Completed initialization of buffer pool
    111218 14:18:14  InnoDB: Started; log sequence number 0 44233
    111218 14:18:14 [ERROR] Can't start server: Bind on TCP/IP port: Cannot assign requested address
    111218 14:18:14 [ERROR] Do you already have another mysqld server running on port: 3306 ?
    111218 14:18:14 [ERROR] Aborting
    At the beginning of the log it says:


    Code:
    111211  3:42:27 [Note] Plugin 'FEDERATED' is disabled.
    111211  3:42:27  InnoDB: Initializing buffer pool, size = 8.0M
    111211  3:42:27  InnoDB: Completed initialization of buffer pool
    InnoDB: The first specified data file ./ibdata1 did not exist:
    InnoDB: a new database to be created!
    111211  3:42:27  InnoDB: Setting file ./ibdata1 size to 10 MB
    InnoDB: Database physically writes the file full: wait...
    111211  3:42:27  InnoDB: Log file ./ib_logfile0 did not exist: new to be created
    InnoDB: Setting log file ./ib_logfile0 size to 5 MB
    InnoDB: Database physically writes the file full: wait...
    111211  3:42:27  InnoDB: Log file ./ib_logfile1 did not exist: new to be created
    InnoDB: Setting log file ./ib_logfile1 size to 5 MB
    InnoDB: Database physically writes the file full: wait...
    InnoDB: Doublewrite buffer not found: creating new
    InnoDB: Doublewrite buffer created
    InnoDB: Creating foreign key constraint system tables
    InnoDB: Foreign key constraint system tables created
    111211  3:42:28  InnoDB: Started; log sequence number 0 0
    111211  3:42:28  InnoDB: Starting shutdown...
    111211  3:42:33  InnoDB: Shutdown completed; log sequence number 0 44233
    111211  3:42:33 [Note] Plugin 'FEDERATED' is disabled.
    111211  3:42:33  InnoDB: Initializing buffer pool, size = 8.0M
    111211  3:42:33  InnoDB: Completed initialization of buffer pool
    111211  3:42:33  InnoDB: Started; log sequence number 0 44233
    111211  3:42:33  InnoDB: Starting shutdown...
    111211  3:42:38  InnoDB: Shutdown completed; log sequence number 0 44233
    111211  3:42:38 [Note] Plugin 'FEDERATED' is disabled.
    111211  3:42:38  InnoDB: Initializing buffer pool, size = 8.0M
    111211  3:42:38  InnoDB: Completed initialization of buffer pool
    111211  3:42:39  InnoDB: Started; log sequence number 0 44233
    ERROR: 1064  You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALTER TABLE user ADD column Show_view_priv enum('N','Y') CHARACTER SET utf8 NOT ' at line 1
    111211  3:42:39 [ERROR] Aborting
    What is your reckoning?

    Kind regards,
    Marius

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    Is this a fresh install? Did you do the mysqladmin portion of setting the root password and all that?

    Code:
    mysqladmin -u root password 'passwordyouwant'
    linux user # 503963

  3. #3
    Just Joined!
    Join Date
    Dec 2010
    Posts
    39
    Quote Originally Posted by scathefire View Post
    Is this a fresh install? Did you do the mysqladmin portion of setting the root password and all that?

    Code:
    mysqladmin -u root password 'passwordyouwant'

    Thanks man, but that failed. What do you reckon:


    Code:
    $ sudo mysqladmin -u root password abc123abc123
    mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
    Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
    Kind regards,
    Marius

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    linux user # 503963

  6. #5
    Just Joined!
    Join Date
    Dec 2010
    Posts
    39
    Quote Originally Posted by scathefire View Post
    Thanks for the reply, the problem is I cannot complete step 4 because as root I do:


    Code:
    $ mysql -u root --password=myrootpassword
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    Same error as before, basically.

    What do you reckon is going on?

    Thanks man.M

  7. #6
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    Check under /etc/, look for my.cnf (maybe under /etc/mysql? or just /etc/ not sure).

    Look for bind-address, make sure its set correctly.
    linux user # 503963

  8. #7
    Just Joined!
    Join Date
    Dec 2010
    Posts
    39
    Quote Originally Posted by scathefire View Post
    Check under /etc/, look for my.cnf (maybe under /etc/mysql? or just /etc/ not sure).

    Look for bind-address, make sure its set correctly.
    The above fixed my problem.

    Thanks man!

    Kind regards,
    Marius

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •