Find the answer to your Linux question:
Results 1 to 7 of 7
It would seem that my window manager is being messed up by the variable LC_CTYPE. From doing a little research it needs to be set to en_US before X starts. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    16

    Lubuntu - wHow do I set LC_TYPE=en_US


    It would seem that my window manager is being messed up by the variable LC_CTYPE. From doing a little research it needs to be set to en_US before X starts.

    (Not enough posts to post links yet)
    Please Google the article "hackerfactor twm"

    How can this be done on Lubuntu as it starts X when the system boots?

    Here is a picture of my problem you can see the title bars and menus are being rendered double scale.

    (Can't post links you'll need to modify the one below)
    imageshack.us/photo/my-images/21/screenshotmcu.png/

  2. #2
    Just Joined! mewmew's Avatar
    Join Date
    Jan 2012
    Location
    Somewhere between Ft. Bragg, NC, Ft. Gordon, GA, and Camp Arifjan, Kuwait.
    Posts
    1
    To do what you're trying to do, you need to use
    Code:
    sudo nano /etc/environment
    and add the line
    Code:
    LC_CTYPE=en_US
    if LC_CTYPE is not already defined in the file. Then do a full reboot.

    (all this according to help.ubuntu.com/community/EnvironmentVariables#List_of_common_environment_va riables)

  3. #3
    Just Joined!
    Join Date
    Dec 2011
    Posts
    16
    Thanks for the help but the fix didn't seem to change anything after a reboot. TWM and vTWM both still have double sized text.

    Oddly enough my system has become unstable after the change (system freezing and keyboard lights blinking). This cannot be directly tied to the change so I can't say for sure that was the problem. I do know it did not appear to fix my dilemma.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Look for this directory:

    /etc/X11/xinit/

    In it, see if these files exist:

    XClients
    xinitrc

    modify one of them to add your hack (put it before the exec of twm, etc.) and see if that works.

  5. #5
    Just Joined!
    Join Date
    Dec 2011
    Posts
    16
    Hmm, I don't know that that helped either. I find it sort of annoying that the *buntu flavors sort of take over login and display managers. It makes it difficult to know exactly where the entry point is into X11.

    This information might help you.
    (prefix with h t t p: if need be)
    imageshack.us/photo/my-images/42/screenshotukg.png/

    Thanks again.

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    What about using LANG="en_US" instead of the other variable name?

    I know that gets set on my RH/Fedora systems in the /etc/sysconfig/i18n file, but that probably doesn't exist on your *buntu box. Try looking for LANG or LC_CTYPE getting setting somewhere, e.g.:

    Code:
    find /etc/ -type f -exec egrep -H "(LANG|LC_CTYPE)" {} \;
    Edit: run that find command as root, or pipe the permission errors to /dev/null to make sense of the output
    Last edited by atreyu; 01-13-2012 at 05:27 AM. Reason: forgot find variable

  7. #7
    Just Joined!
    Join Date
    Dec 2011
    Posts
    16
    Thanks atreyu.
    Hopefully this will help others.

    There is a file in lubuntu called
    /etc/default/locale:"LANG=en_US.UTF-8"
    I changed it to:
    /etc/default/locale:"LANG=en_US"
    Then selected Default for the language selection on the login screen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •