Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unhappy ssh from outside to home ubuntu failed

    I have set up portforwarding with my buffalo air station and have set up ssh in my ubuntu. I was able to connect to my ubuntu from outside but now i fail. Not sure what has been changed/wrong
    1. port forwarding is setup, from router Internet IP to local lan IP, e.g.
    Internet:22 -->

    2. Firewall disable for port 22

    3. Ssh from within works, so sshd is configured correctly
    [martin<> localhost ~]$ ssh
    The authenticity of host ' (' can't be established.
    RSA key fingerprint is 47:29:03:3f:b5:87:90:1b:58:67:52:82:f4:6a:7c:9d.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added '' (RSA) to the list of known hosts.
    Last login: Sat Feb 4 10:24:49 2012 from localhost.localdomain
    [martin<>localhost ~]$ telnet 22
    Connected to
    Escape character is '^]'.

    Protocol mismatch.
    Connection closed by foreign host.
    (all at sign replaced by <>)

    anything else i should check?
    Attached Images Attached Images

  2. #2
    Correction: Internet:22 --> , Internet means my router internet address

  3. #3
    And connect to the internet address from inside failed
    [martin<>localhost ~]$ ssh <Internet address>
    ssh: connect to host <Internet address> port 22: Connection refused

  4. $spacer_open
  5. #4
    More info, there is no IP restriction on my own sshd, in /etc/ssh/sshd_config

    Port 22
    #AddressFamily any
    #ListenAddress ::

    Also, no firewall set in my router to block port 22
    Screenshot-AirStation Settings - Mozilla Firefox.jpg

  6. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Do you have a static IP address from your ISP, or is it dynamic? If dynamic, then that is your problem since you cannot know externally what the actual IP address of your router is. In any case, even though you may have the same dhcp address for some period of time, that can change at any time when the lease expires.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts