Find the answer to your Linux question:
Results 1 to 2 of 2
Ubuntu 11.4, 64 bit, also failed the same on Ubuntu 11.11 When plugging in this external drive, I can only see under Disk utility tool, but I cannot format the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    55

    USB drive not working


    Ubuntu 11.4, 64 bit, also failed the same on Ubuntu 11.11

    When plugging in this external drive, I can only see under Disk utility tool, but I cannot format the drive (using MBR format). The error is:

    Error creating partition table: helper exited with exit code 1: cannot open /dev/sdb: No such device or address

    When I use gparted, it doesn't see the drive at all.

    Plugging into Windows 7, I can see and write files to the drive without problem. It's NTFS. If I take out the drive from the enclosure, and put it directly into the laptop, I can read and write to it. The case is Rocketfish USB 3 SATA, can be seen here:

    http://www.amazon.com/Rocketfish-Rf-.../dp/B004MEZ5IM

    Looking at the system message after plugging in the drive (
    sudo tail -c 0 -f /var/log/syslog), I get the following:

    Feb 15 20:30:49 SOMENAME kernel: [ 473.540142] usb 2-3: new high speed USB device using ehci_hcd and address 6
    Feb 15 20:30:50 SOMENAME kernel: [ 473.702388] scsi5 : uas
    Feb 15 20:30:50 SOMENAME kernel: [ 473.905074] scsi 5:0:0:0: Direct-Access SYMWAVE INTEL SSDSA2BW16 LE04 PQ: 0 ANSI: 4
    Feb 15 20:30:56 SOMENAME kernel: [ 480.060102] scsi 5:0:0:0: uas_eh_abort_handler tag 0
    Feb 15 20:30:56 SOMENAME kernel: [ 480.060115] scsi 5:0:0:0: uas_eh_device_reset_handler tag 0
    Feb 15 20:30:56 SOMENAME kernel: [ 480.060123] scsi 5:0:0:0: uas_eh_target_reset_handler tag 0
    Feb 15 20:30:56 SOMENAME kernel: [ 480.060130] scsi 5:0:0:0: uas_eh_bus_reset_handler tag 0
    Feb 15 20:30:56 SOMENAME kernel: [ 480.180130] usb 2-3: reset high speed USB device using ehci_hcd and address 6
    Feb 15 20:30:56 SOMENAME kernel: [ 480.332114] scsi 5:0:0:0: Device offlined - not ready after error recovery
    Feb 15 20:30:56 SOMENAME kernel: [ 480.332198] scsi 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:30:56 SOMENAME kernel: [ 480.332220] scsi 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:30:56 SOMENAME kernel: [ 480.334159] scsi 5:0:0:1: Enclosure SYMWAVE SES LE04 PQ: 0 ANSI: 4
    Feb 15 20:30:56 SOMENAME kernel: [ 480.334373] scsi 5:0:0:2: uas_sense_old: urb length 26 disagrees with IU sense data length 510, using 18 bytes of sense data
    Feb 15 20:30:56 SOMENAME kernel: [ 480.334980] sd 5:0:0:0: Attached scsi generic sg2 type 0
    Feb 15 20:30:56 SOMENAME kernel: [ 480.335173] ses 5:0:0:1: Attached Enclosure device
    Feb 15 20:30:56 SOMENAME kernel: [ 480.335331] ses 5:0:0:1: Attached scsi generic sg3 type 13
    Feb 15 20:31:27 SOMENAME kernel: [ 511.120129] sd 5:0:0:0: uas_eh_abort_handler tag 0
    Feb 15 20:31:27 SOMENAME kernel: [ 511.120144] sd 5:0:0:0: uas_eh_device_reset_handler tag 0
    Feb 15 20:31:27 SOMENAME kernel: [ 511.120152] sd 5:0:0:0: uas_eh_target_reset_handler tag 0
    Feb 15 20:31:27 SOMENAME kernel: [ 511.120159] sd 5:0:0:0: uas_eh_bus_reset_handler tag 0
    Feb 15 20:31:27 SOMENAME kernel: [ 511.240133] usb 2-3: reset high speed USB device using ehci_hcd and address 6
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391767] sd 5:0:0:0: Device offlined - not ready after error recovery
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391853] sd 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391875] sd 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391887] sd 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391896] sd 5:0:0:0: [sdb] READ CAPACITY failed
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391902] sd 5:0:0:0: [sdb] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391911] sd 5:0:0:0: [sdb] Sense not available.
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391922] sd 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391932] sd 5:0:0:0: [sdb] Write Protect is off
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391938] sd 5:0:0:0: [sdb] Mode Sense: 00 00 00 00
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391947] sd 5:0:0:0: rejecting I/O to offline device
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391956] sd 5:0:0:0: [sdb] Asking for cache data failed
    Feb 15 20:31:27 SOMENAME kernel: [ 511.391961] sd 5:0:0:0: [sdb] Assuming drive cache: write through
    Feb 15 20:31:27 SOMENAME kernel: [ 511.392355] sd 5:0:0:0: [sdb] Attached SCSI disk


    I found a question that is very similar to the following post:

    http://askubuntu.com/questions/91520...unted-on-11-10

    and the bug linked in that post:

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/875523
    Last edited by hovh03; 02-16-2012 at 01:00 AM.

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    55
    After adding the "blacklist uas" into /etc/modprobe.d/blacklist.conf and restarted, I also did this:

    sudo rmmod uas

    I then plug it in, and a dialog popped on on Ubuntu saying cannot mount the device. However, I can see it in the Disk Utility.
    I try to mount there with a same error. However, after I reformat the drive, and then create a partition, formatted as NTFS, and it now works.

    There is a tracker for this here:

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/828471

    There is also a related/same problem here, and may have been fixed with the latest kernel:

    https://bugzilla.redhat.com/show_bug...iple&id=717633

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •