Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, First of all, I want to thank You in advance for patience, since I'm a complete noob in terms of Linux advanced features. Some time ago I installed triple ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    2

    triple boot (2x Win7 + 1x Ubuntu) NTLDR + grub no ang0 problem


    Hi,

    First of all, I want to thank You in advance for patience, since I'm a complete noob in terms of Linux advanced features.

    Some time ago I installed triple OS on my laptop.
    1. Windows 7 x64
    2. Windows 7 x64
    3. Ubuntu

    I do not remember how exactly I managed to make all these work, since I was installing it all with help from my more-linux-aware friend who I cannot contact now, but I remember that EasyBCD was used for the installation.

    When I started my system I had a "classic" Windows boot NTLDR with 3 specific choices, as above. When I chose 1 or 2 it just booted into chosen Windows. When I chose Ubuntu, it moved on to Grub and from there the Ubuntu started.

    I do not use Ubuntu too often, just for network testing with iperf, sometimes mtr etc, not many more. I didnt use it for a couple of weeks, but never had any issues with it earlier.
    Today, when I tried to load Ubuntu it stopped before showing me the grub menu as it did before (but after NTLDR and picking "Ubuntu" - so I guess the "windows" loader is fine and there is something wrong with grub). What it shows me now is:

    Try (hd0,0): NFTS5; No ang0
    Try (hd0,1): NTFS5; No ang0
    Try (hd0,2): NTFS5; No ang0
    Try (hd0,3): Extended;
    Try (hd0,4): EXT2: No ang0
    Try (hd0,5): Extended;
    Try (hd0,5): non-MS: skip
    Try (hd1,0): NTFS5: no ang0
    Try (hd1,1): invalid or null
    Try (hd1,2): invalid or null
    Try (hd1,3): invalid or null
    BIOS: Drive=0x0, N=0, S=0

    Try (fd0): invalid or null
    Cannot find ang0 in all drives. Press Ctrl+Alt+Del to restart

    Here's what EasyBCD says now:
    easybcd.jpg

    All three OS's are located on the same physical disk 0.

    Any guesses how to restore my Ubuntu and why Grub got (I guess) destroyed?

    ps. I tried the search option, but couldn't find anything with exactly the same triple boot scenario

    Thanx!

  2. #2
    Just Joined!
    Join Date
    Mar 2012
    Posts
    2

    Solved

    I see no answers, so I will just add info, in case in the future someone comes along a similar problem:

    solved with some help from Neosmart Support: there was a problem with AutoNeoGrub files/dirs created by EasyBCD.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,167
    Posting your self-discovered solutions to your problems here always helps. Others may benefit from your experience/pain! Thanks, and more details might be helpful.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    drl
    drl is offline
    Linux Engineer drl's Avatar
    Join Date
    Apr 2006
    Location
    Saint Paul, MN, USA / CentOS, Debian, Slackware, {Free, Open, Net}BSD, Solaris
    Posts
    1,260
    Hi.

    See triple boot (2x Win7 + 1x Ubuntu) NTLDR + grub no ang0 problem for some details ... cheers, drl
    Welcome - get the most out of the forum by reading forum basics and guidelines: click here.
    90% of questions can be answered by using man pages, Quick Search, Advanced Search, Google search, Wikipedia.
    We look forward to helping you with the challenge of the other 10%.
    ( Mn, 2.6.n, AMD-64 3000+, ASUS A8V Deluxe, 1 GB, SATA + IDE, Matrox G400 AGP )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •