Hello. I'm using ubuntu 10.04. I have installed freeglut3 & freeglut3-dev and compiled a gl/glu/glut program. when i tried to run it i got:
ERROR: Internal error <FBConfig with necessary capabilities not found> in function fgOpenWindow
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 4 (X_DestroyWindow)
Resource id in failed request: 0x0
Serial number of failed request: 30
Current serial number in output stream: 33

Assuming tjat the bug is in glut runtime i have removed the freeglut3 and installed another version of freeglut & got the same error. what am i doing wrong?